WordPress.org

Support

Support » Installation » Problem with widgets.php in Upgrading from WP 2.1 to WP 2.5

Problem with widgets.php in Upgrading from WP 2.1 to WP 2.5

  • I’m trying to upgrade from WP 2.1 to WP 2.5 at http://www.gauravonomics.com/diary, but I’m getting the following error:-

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/azrhrba/public_html/diary/wp-includes/widgets.php on line 654

    Warning: Invalid argument supplied for foreach() in /home/azrhrba/public_html/diary/wp-includes/widgets.php on line 654

    Please help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Edit your text widgets and resave them. Don’t leave any of them empty.

    @otto: I have deleted all the old plugins. In fact, I have kept nothing from before except my /wp-contents/uploads folder, and my wp-config.php and .htaccess files.

    I am having the same problem I think – please see my posting titled Upgrading to 2.5 is a Disaster (http://wordpress.org/support/forum/2)

    I have checked with my hosting company but they say it’s an issue with WordPress that only WordPress can solve because it’s the new 2.5 WordPress and they don’t have any information.

    I can’t login even to change anything.

    We tried going back to WordPress 2.3, but it doesn’t help.

    Please help us!

    I have now tried everything from going back to WP 2.3.1 to deleting ALL files and doing a FULL fresh install but it doesn’t work.

    Please help.

    i think I’m having the same problem.

    I went through the wp_options table and deleted the rows for the default widgets, widget_categories, widget_anything, widget_pages,widget_calendar, and widget_archives and the error went away. I’m not interested in finding out if one specific one was the culprit, so perhaps one could go through each of those one by one to find out which might have been the problem.

    The old widget_text option is, in fact, the culprit, as I stated before. Clearing or resaving your text widgets will generally fix this issue.

    I didn’t touch widget_text, unless that’s widget_anything now. I’d never touched the default widgets, so I didn’t have anything to “edit”, and didn’t think to go in and edit seemingly non-existent content.

    I had a similar issue. Deleting the widget entries fixed it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problem with widgets.php in Upgrading from WP 2.1 to WP 2.5’ is closed to new replies.
Skip to toolbar