Support » Plugin: MonsterInsights - Google Analytics Dashboard for WordPress (Website Stats Made Easy) » Problem with Version 7.7.0 and WordPress 5.2.2

  • Resolved ScalarEnt

    (@scalarent)


    Hi, I just updated my test site to WordPress 5.2.2 and then tried to update your plugin to version 7.7.0.

    WordPress flagged an error and went into recovery mode:

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 49 of the file {path removed}/wp-content/plugins/google-analytics-for-wordpress/lite/includes/load.php. Error message: require_once(): Failed opening required ‘{path removed}/wp-content/plugins/google-analytics-for-wordpress/lite/includes/admin/wp-site-health.php’ (include_path=’.:/usr/share/pear7:/usr/share/php’)

    I disabled the plugin in recovery mode and all worked again.

    Thought you would like to know.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author chriscct7

    (@chriscct7)

    Hi there,
    We’ve issued an update for this.

    SVN didn’t add one of our files, ugh.

    Version 7.7.1 should solve this issue

    Sorry about that

    -Chris

    Login via FTP or web hosting dashboard and delete the MonsterInsight plugin folder ~/public_html/wp-content/plugins/google-analytics-for-wordpress

    This resolved it for me until they can get around to fixing the broken plugin.

    Thread Starter ScalarEnt

    (@scalarent)

    Wow, that was quick.

    Many thanks

    Plugin Author chriscct7

    (@chriscct7)

    @scalarent not a problem!

    @problemsolved an updated version to resolve this has already been issued.

    Same Issue here, used “recovery mode” to deactivate the plug in, which brought the admin dashboard back. Waiting for the update to come through before reactivating.

    @problemsolved you didn’t need to ftp to delete the folder, just deactivate. That way you wouldn’t need to do a complete reinstall and setup. Or at least I think!

    Update, yes it worked fine after updating to 7.7.1 over the broken 7.7.0
    Reactivated and all is well again.

    • This reply was modified 2 years, 4 months ago by Pip.
    Thread Starter ScalarEnt

    (@scalarent)

    FYI – I deactivated the 7.7.0 plugin in recovery mode but WordPress 5.2.2 would not let me actually delete it – said there was still a problem.

    Presumably if I re-activated 7.7.0 in order to try and update it, it would just fail again so it needs to be deleted via ftp in order that you can install the new version (7.7.1).

    Plugin Author chriscct7

    (@chriscct7)

    Hi there,
    For future reference, you can force WordPress to find new plugin updates via the Updates page as shown here: https://www.wpbeginner.com/plugins/how-to-force-wordpress-to-check-for-plugin-updates/

    That being said, we’re going to be looking into how we can automate a test for this type of plugin repository issue so our users never have this issue again, and ideally in a way we can share with the rest of the WP community plugin authors as well.

    -Chris

    This error has happened to me too. However the recovery mode isn’t working for me so I can’t deactivate the plugin and reinstall the updated version. I got the recovery email from wordpress but it says ‘recovery mode not activated’ when I click on it! Guess I’ll have to log in using FTP!

    aargh!

    Very glad to hear there’s an update to fix this so quickly! Once I can get back in I’ll update!

    Hi @emmals,

    I’m sorry to hear that. :-/

    If the issue persists you can contact us at https://www.monsterinsights.com/lite-support/ and we’ll help get it sorted.

    Thanks,
    -Jay

    @scalarent
    I updated the plugin with the old one still installed but deactivated. The update worked, then I activated the updated version. I didn’t need to delete anything.

    Thread Starter ScalarEnt

    (@scalarent)

    Hi Pip – that good to know, thanks.

    Hi All!

    I have a new site with wordpress 5.5.2. After activating GA Monsterinsights Plugin 7.7.1, my site became very-very slow.
    In addition, I found a quite big chunk-vendors.js file on every page and sub-page. I have other websites too, using GA Monsterinsights, but with previous wordpress version, and I did not find this vendor file on those sites.
    So I’ve deactivated the plugin on this site, and page speed became much higher.
    So do you think it was the problem?
    Thanks, Anita

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Problem with Version 7.7.0 and WordPress 5.2.2’ is closed to new replies.