Support » Plugin: Product Feed PRO for WooCommerce » Problem with variations title (greek language)

  • Resolved dontwonnatellyou

    (@dontwonnatellyou)


    Hi,

    Recently we noticed that we have a problem with the title of product variations.

    Our site uses the greek language only, so the product titles are all in greek.

    For simple products we have no problem, the product title in xml appears correctly in greek language.

    But for products that have variations the default part of the product, appears correctly in greek language, but the part that has the attributes & values appears in percent encoding style.

    For example : Πίατο ζαρνινιέρας Anthea %cf%80%ce%b6-%ce%bd%ce%bf-413-93-x-20 %ce%ba%cf%85%cf%80%ce%b1%cf%81%ce%b9%cf%83%cf%83%ce%b9
    default product name : Πιάτο ζαρνινιέρας Anthea (appears correctly)
    From the rest, i guess the first part is the greek word dimension and the dimension of the product (413 – 93×20) and the latter must be the colour of the product.

    We are using the lattest version of the plugin 6.6.4

    Thanks in advance for your efforts
    manos

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi Manos,

    Thanks for using our plugin and reaching out to us. We have tried to replicate the issue at hand, for us it seems to work just fine.

    Could you show me the exact attribute names and values in proper Greek so I can try copying those in our development website to see what happens?

    All the best,
    Eva

    Thanks for your quick reply.

    The attribute names (in question) are :

    (i) Διαστάσεις (slug is the same), possible values (for example : ΠΖ No 463 // 93 x 36 εκ , ΠΖ Νο 409 // 37 x 17, etc).
    (ii) Χρώμα (slug is same), possible values (for example: κίτρινο, κόκκινο, τερακότα).

    In the middle time, i made a test product with all possible attributes & values we have, and we have the same problem in all attributes in new products. …
    (More attributes & values)
    (iii) Εγγυήση , possible values (10 έτη, 3 έτη, …)
    (iv) Ποικιλία, possible values (αθήρι, αγιωργήτικο, …)
    etc..

    Here is a temp feed i made : https://e-paradeisos.gr/wp-content/uploads/woo-product-feed-pro/xml/JoYt2s8f2oSmBCZfnIjzyl5iTBf9ix3k.xml

    WordPress version 5.2.3–el, woocommerce 3.7.0

    Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi Manos,

    Thanks for this extra information. We have put some time in it and it is a bit of a technical explanation but it seems WordPress sanitized the variantion attribute values before it saves it to the database. When the values are then displayed on your website the browser is able to undo the sanitization and shows the normal Greek words. Unfortunately this does not seem to work when the data needs to be put in a product feed.

    You could, alternatively, choose not to append the attribute values to the product name so the variable parent productname is used for the variants. You can do so by changing the field mapping for the g:title field to the “Product name parent product”, like this: https://www.dropbox.com/s/zui369dwodyeom9/product_name_parent.png?dl=0

    Hope this is an option for you?

    All the best,
    Eva

    Hi,

    Thank you for your reply.

    I think that we are going to have a problem with our marketing channel (skroutz) with the suggested solution .

    We had products with variations before, and we didn’t had any problems so far. Did anything changed in your add-on or did wordpress changed something?

    What i really don’t understand is the following image. (https://drive.google.com/open?id=13D1JpV4KPQO8ROBtdjjEScfIkZQPAeDJ).

    The left feed is the one serving to our marketting channel right now (updated every hour), and the right feed is the test feed i send it to you.
    Same product(id 2906-5, product was created about a year ago), but different titles. The old (official) feed is still sending the correct data to our marketting channel, new feed sends wrong data.

    But in the new products, both feeds send incorrect data for title.

    Thanks in advance
    manos

    Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi Manos,

    I think you are right, somewhere in the previous releases WooCommerce made a change in the output of a WooCommerce function, the output become sanitized and that’s what you are seeing in your product names for new products. Since this sanitation did not take place for your older products when they were put in the database they are still fine.

    The good new is that we have designed a solution for it and just pushed out a new version of the plugin that should solve the issue at hand. Could you try updating our plugin to the latest version and test if it solves the issue?

    All the best,
    Eva

    Issue has been solved.

    Thank you, for your great support.

    Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi Manos,

    You are welcome, glad the issue at hand has been solved. Thanks for reporting the issue and leaving a review. Greatly appreciated!

    All the best,
    Eva

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Problem with variations title (greek language)’ is closed to new replies.