Support » Plugin: Hyyan WooCommerce Polylang Integration » Problem with variable products

  • Hi everyone,

    I’m having an issue with setting up translations for variable products and I wonder if anyone can help me with this.

    I’m using woocommerce 2.4.10, polylang 1.7.12 and Hyyan’s integration plugin.

    When I create a translation for a variable product the translated product is generated has a simple product, and all the variations are gone.

    On the front-end the add to cart button and the product variations select boxes are missing on both, the original product page and the translation.

    Maybe there’s a compatibility issue with “Hyyan woocommerce polylang integration” and the wordpress version i’m running (4.3.1)

    Could please anyone give me a hint on what’s going on?

    https://wordpress.org/plugins/woo-poly-integration/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Augustin, thanks for the suggestion but I’ve just solved this issue.

    I’ve tried to install the storefront theme and an older version of wordpress (2.2.5) on my site, but it turned out that it hasn’t the problem.

    I kept on getting the same error for variable products translations, the attributes disappeared from the back and front end of the store.

    At the end I realized that I wasn’t able to set variable products for a second language, because I had to translate the attributes for this product before I proceed.

    Thanks Hyyan for this great plugin, it’s the best solution for me to translate the products from my store

    I think I have a similar issue.

    Catarina,
    where did u translate the attributes? I don’t see it in the string translations.

    Hi,

    Actually what you have to translate is the attribute terms.

    In the WP adim panel you have to go to “products” > “attributes”, and when creating a new term for an attribute you can also create its translations: below the attribute description box you have a section called “language” and “translations”.

    If you already have created your terms, you can add translations to them by clicking on the “configure terms” button, on the attributes table, and then clicking on the flag item on witch term.

    Them you can also add label translation for your attributes on the “translate attribute labels” button, above the attributes table.

    That should work =)

    Hi,

    Thanks for your explanation.
    I translated all the attributes but I sill have the issue …
    Attributes are not displayed in the translated products.
    COuld someone help me to resolve this issue?

    Thanks in advance,
    CĂ©line

    After you created a Product Attribute under Admin > Products > Attributes, click on the button “Translate Attributes Labels”. This will open the Polylang’s Strings Translation page where you can translate your just created product attribute.

    Now, you need to create and translate the product attributes terms. Go to Admin > Products > Attributes and click on the name of the product attribute. This will open a page where yoiu can create the attributre terms. For example: if your attribute is Colour, your terms are blue, green, red,etc. You can use the normal Polylang functionality to translate the terms.

    Now ahead to Admin > Products > Add Product and create your product. Click on Attributes and from the dropdown box choose your attribute, in my example colour. Click the Add button and in the input field write the terms you have created before, or simply select all terms by clicking the button Select All.

    If you are creating a Variable Product, don’t forget to select Variable Product in the dropdown box so that the option “Use as variation” is shown.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem with variable products’ is closed to new replies.