Support » Plugins and Hacks » Contact Form 7 » [Resolved] Problem with UTF-8 or multi-tag in email Subject

[Resolved] Problem with UTF-8 or multi-tag in email Subject

  • Hello,
    If I write text in UTF8 charset in subject field the form wouldn’t send and a red error appears, but if I insert a tag which contains utf8 text it works!

    next problem: When I try ti put 2 tags in subject field it fails again. i.e. I’ve tried to insert this string as subject but it failed:
    [order_type] [sender_name]
    each of them works separately.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Takayuki Miyoshi


    Odd situation. Could you share the URL of the site? And what UTF-8 text exactly?

    I tried on two sites. How you can test it as a guest?!! I think there’s a misunderstanding. subject field is not a field in output form, I mean the “subject” field in form creation panel.
    here’s are some text examples in Persian language as constant subjects:
    تماس از وبسایت
    ثبت سفارش
    تبادل لینک

    but if I use a tag in that subject which contains UTF-8 text it works fine.
    for example we have a text field for name, i.e. [text1] and we insert it in subject field and save the form. Now if a user fill the field with UTF-8 contents “ثبت سفارش” it will be sent without any problem, but if I write that entry directly in subject field and save the form it wouldn’t work.

    If you want I can create a test post with both conditions to try them.


    Plugin Author Takayuki Miyoshi


    I just tested it on my local environment, but couldn’t reproduce the problem what you wrote. I directly set “تماس از وبسایت” in the Subject field in the Mail section, but the form got submitted successfully and I recieved the correct mail.

    Maybe there is another factor relating to the problem in your environment. Could you tell what other plugins and what theme do you use? If possible, try deactivating all other plugins and switching to the default theme, then try the form again.

    Also, can you check your PHP error log? I suppose you can find some clues there.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Problem with UTF-8 or multi-tag in email Subject’ is closed to new replies.
Skip to toolbar