Support » How-To and Troubleshooting » Problem with uploads

Problem with uploads

  • All the threads I’ve read don’t seem to help on my particular problem.

    I’ve not been able to use my upload function in wordpress.
    My permissions are wp-content: 777 and my directory uploads: 777.
    I changed these permissions on my server control panel.

    here is the error I get: –

    ‘The uploaded file could not be moved to /home/mysite/public_html/wp-content/uploads.
    Warning: Cannot modify header information – headers already sent by (output started at /home/mysite/public_html/wp-admin/admin-functions.php:1879) in /home/mysite/public_html/wp-includes/functions.php on line 1219′

    many thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • I realise the topic is suspiciously like a thousand others but let me assure you this is not a simple rights issue.
    I’ve re-installed wordpress 2.1.3 and still the same error?
    Any advice?

    I’d agree that permissions are not the problem but rather ‘white space’ in a script file.

    See: How do I solve the Headers already sent warning problem?

    After my initial searches I cleared any ‘white space’ in the relevant php files but still the same error. I’m starting to think it could be a server issue?

    wp_die( printf( __('The uploaded file could not be moved to %s.' ), $uploads['path'] ));

    the above line seems to be where the trouble starts?

    I have exactly the same problem and have double checked that there are no characters before or after the code.

    Any clues on this problem? Could it be a server issue?

    sorry for the bump, can anyone on the afternoon shift help?

    up we go

    I have finally resolved this problem! My host offers the option of running in PHP4 FastCGI mode. They say “This provides a more secure method of running PHP4 programs and has the added benefit that no special measures are needed in order to grant write access to your webspace for PHP scripts.”

    I selected this option and now, without doing anything else like CHMOD, I can upload images!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problem with uploads’ is closed to new replies.