Support » Theme: Goran » Problem with uploading logo in Goran

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    The logo shows in the customise section but the mouse has turned into a sphere that just keeps turning and turning and turning and it doesn’t finish so that I can save and publish.

    I’m not sure this is a theme issue; it could be a problem with your WordPress installation itself, a plugin conflict, a network issue or something else.

    Are you having the same trouble saving other customizations – such as a custom header image or background colour – or only having trouble with the logo?

    Here are a few troubleshooting steps you could try, to narrow down the issue:

    – switch to another theme that supports a Jetpack logo like Sela and see if the issue remains
    – try temporarily deactivating all your plugins. Does the problem persist? If the problem is gone, reactivate your plugins one-by-one, look at the site in between each reactivation, to find the conflict.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    When deactivating your plugins, you’ll need Jetpack for the site logo feature, but try deactivating all the individual modules you’ve been using and then reactivating them one at a time. Be sure to make a note of which modules you’re using first. 🙂

    by modules, what do you mean exactly? The plugins or something else?

    I’ve disabled the plugins but kept jetpack working and tried again. At least the mouse doesn’t go round and round and it says it’s saved but it’s still not showing.

    When I disabled jetpack and tried again it had this message:
    Warning: Creating default object from empty value in /home/diamondplanning/public_html/wp-content/themes/goran/inc/customizer.php on line 21

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Thanks for letting me know how the testing went.

    I’m going to ask our developers to look into this so we can get to the bottom of it. I’ll keep you posted here.

    by modules, what do you mean exactly? The plugins or something else?

    Jetpack comes with individual modules that you can activate or turn off independently under Jetpack > Settings.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    I’ve been doing some testing and I definitely see some issues when previewing the logo in the Customizer, but after saving the logo is appearing on the front end of the site in my testing. Would you mind confirming that after you’ve added the logo in the Customizer you’re clicking the Save button at the top, even if you don’t see the logo in the preview portion of the Customizer?

    Yes, I’m adding the logo in the customiser section. And then saving it, even though it doesn’t show in the preview section.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Thanks for confirming, I’ve passed this along to our developers.

    Could you try turning off all the Jetpack modules under Jetpack > Settings and see if that helps? The site logo should work as long as Jetpack is still active, it doesn’t require any specific modules. (Make a note of which modules you’re using so you can reactivate them later.)

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    proverbs31woman – we’ve found an issue in one of the theme files that causes the PHP error you’re seeing. We’ve fixed the issue and are resubmitting the theme to the directory now, but if you’d like to try this in the meantime, it may solve the issue with the logo not updating correctly.

    You’d need to locate this file:

    wp-content/themes/goran/inc/customizer.php

    …and comment out line 21, by placing two slashes in front of it, like this:

    //$wp_customize->get_setting( 'site_logo' )->transport = 'refresh';

    After doing that, could you let me know if the site logo upload works correctly?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problem with uploading logo in Goran’ is closed to new replies.