WordPress.org

Support

Support » Multisite » [Resolved] Problem with uploading and viewing posts

[Resolved] Problem with uploading and viewing posts

  • Hi

    I’m currently stuck in a mapping problem with the MU configuration.
    I use Apache and MAMP so Ive mapped the subdomains representing my blogs in a VirtualHost-tag inside httpd.conf to my local domain. It works to view each blogs start page but to view a specific post wont work. The server would just throw a 404.

    Same thing with uploading media, the uploaded file lands right in blogs.dir but wont read from the same folder so the pictures just come out blank. I figured out that its trying to read the /files catalog but that one resides in the wp-content root, while I want WP to look for the blog’s own files directory inside blog.dir/(number)/files.

    I’m also trying to get a newly created blog’s posts in a query on my front page but the user id returns null even though I know its the right id and that it has some posts in it.

    Where should I start looking for this setting?

    Sorry guys If this seems blurry but this really gets me tired.

    /Max

Viewing 3 replies - 1 through 3 (of 3 total)
  • Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    htaccess. 🙂

    It’s not being read. That;s what controls permalinks and the blog’s admin areas, and the image url rewriting.

    got this stuff in it:

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Found that AllowOverride should be set to All in Directory (httpd.conf file), and it fixed my problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Problem with uploading and viewing posts’ is closed to new replies.
Skip to toolbar