Support » Fixing WordPress » Problem with upgrade ( to

  • Resolved nli


    I installed WordPress few days ago and now upgraded it to (from I followed the instructions (at least I believe so) but in the end my blog showed only a blank page. After experimenting with chmod (tried 666 and 777 for files and directories) I got a couple of php errors:

    Warning: main(/home/int2000/14061/html/blogi/wp-includes/wp-db.php): failed to open stream: Permission denied in /home/int2000/14061/html/blogi/wp-settings.php on line 39

    Fatal error: main(): Failed opening required '/home/int2000/14061/html/blogi/wp-includes/wp-db.php' (include_path='.:/usr/lib/php') in /home/int2000/14061/html/blogi/wp-settings.php on line 39

    I’m not too familiar with php so I was not sure what that means. Has it something to do with the database?

    Also, in wp-admin Presentation > Themes did not show any themes. Please see the screen capture:

    Now, I cannot even access the wp-admin since it returns “403 Forbidden” error (probably due my chmod experiments?).

    I’d greatly appreciate any help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • skippy



    See these instructions, but in a nutshell:

    Save a copy of your wp-config.php file somewhere safe. Then delete all your WordPress files. Then re-upload the files from a fresh download. Then restore your wp-config.php.

    Does that work?

    Thanks skippy,that did help. I just lost all the changes I had made to the templates. Fortunately they were not many yet. I just wish I knew what went wrong to succeed better with next upgrade.

    Don’t get rid of your wp-content! Keep it with wp-config.php.




    Sorry, Firas was right. Major oversight on my part.

    I did try before with leaving both wp-config.php and wp-content so I decided to try. Anyway, I had not yet made that many changes.

    I believe I found where the problem was. Is it that chmod for wp-content should be 777? If I modified that I re-encountered the same error. 666 was not enough.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem with upgrade ( to’ is closed to new replies.