Support » Plugin: Relevanssi - A Better Search » Problem with update

  • Resolved gulliver

    (@gulliver)


    When updating from 4.0.4, indexing stalls.

    After…
    Wiping out the index… Done.
    Counting posts… 50 posts found.

    There’s seemingly no activity other than an increasing time counter (and no green progress bar).

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mikko Saari

    (@msaari)

    Try doing a hard refresh, your browser is probably using old Javascript files from the previous version. Click reload while pressing shift. Does that help?

    Thanks.

    I’m wondering whether the ‘using old js’ can be the case… twice I’ve replaced the updated version with the former one, and the effect has been the same – old version works fine, new one doesn’t.

    As I’ve currently reverted to the older version, when I’ve more time I’ll update again and try your suggestion.

    Plugin Author Mikko Saari

    (@msaari)

    That’s the problem in at least 95% of cases I’ve run into.

    The remaining 5% are usually caused by a misbehaving shortcode and fixed by disabling shortcode expansion in Relevanssi settings.

    Thanks.

    The hard-refresh didn’t do it… but that’s not surprising as I’m currently using Opera and which has been particularly stubborn in cacheing stuff and not responding to shift-refresh.

    Switching browsers sorted it, and on a return to Opera the fix was to use /preferences/clear cache… whereupon Opera now behaves. (I’m adding this as a possible help to others who may experience similar issues, and not realise that Opera may be the issue.)

    Thanks again for you help… it’s genuinely appreciated.

    • This reply was modified 2 years, 5 months ago by gulliver.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem with update’ is closed to new replies.