WordPress.org

Forums

Watu
[resolved] Problem with translation (6 posts)

  1. vellkan
    Member
    Posted 2 years ago #

    Hello :)

    I've got problem with translation.
    I've open watu.pot in Poedit, translate some lines and saved it as pl_PL.po in langs folder.
    But it didn't work.

    I've try to rename it to en_US.po, en_UK.po, watu.po but this files didn't work too.

    Last try was to scan .php files in watu plugin folder. But even then translations didn't work.

    What should I do make it work?

    http://wordpress.org/extend/plugins/watu/

  2. prasunsen
    Member
    Plugin Author

    Posted 2 years ago #

    Hello, the .po and .mo names should have watu- prefix:

    watu-pl_PL.po
    watu-pl_PL.mo

  3. vellkan
    Member
    Posted 2 years ago #

    Unfortunatelly, it still didn't work.

    Now I've got this two files in langs folder, but still nothing happen.

    Which watu.ot file should I open in Poedit?
    This from main folder or from /langs folder?

  4. prasunsen
    Member
    Plugin Author

    Posted 2 years ago #

    Did you also set the locale in your wp-config.php file? The .pot file in the root is more actual. I'll remove the other one in the next update

  5. vellkan
    Member
    Posted 2 years ago #

    Yes, I've got set the locale.

    But now everything is OK, I reinstall plugin one more time and eveything works!

    Thanks for quick help, problem resolved!

  6. prasunsen
    Member
    Plugin Author

    Posted 2 years ago #

    Great thanks. If you have a minute please don't forget to submit a review
    http://wordpress.org/support/view/plugin-reviews/watu

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Watu
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic