Support » Plugin: Multi-column Tag Map » Problem with title_divider

  • I use the code so title_divider=”Prof. Dr.,” but it doesn’t work. Where do I make a mistake?

    I have tags like Prof. Dr. Name Surname and I want to hide Prof. Dr. in the listing.

    PS: name_divider=”Name Surname | Prof. Dr.,” does not work either.

    • This topic was modified 7 months, 2 weeks ago by EuroNur.
Viewing 1 replies (of 1 total)
  • Plugin Author tugbucket

    (@tugbucket)

    The issue would be that that’s not how title_divider works. For example:
    [mctagmap title_divider="Prof."] Would ignore the word “Prof.” when sorting and sort Prof. Dr. Name Surname under “D” as designed. See: https://mctagmap.tugbucket.net/options/title_divider/

    For name_divider, that’s not how it works either. For example: [mctagmap name_divider="|"] is the default. So any tag with a | (vertical pipe), would be split at the pipe. So if you had a tag name of Prof. Dr. | Name Surname, that listing would be sorted under the “N” as designed. See: https://mctagmap.tugbucket.net/options/name_divider/

    Neither option hides anything, just rearranges the word and/or sort order.

    In your case you could simply try adding a vertical pipe to your tags and use: [mctagmap] and adding some JavaScript to your theme like:

    	/* remove after name_divider */
    	$('.tagindex .links a').text(function(i, t) {
    		if(t.indexOf(',') >= 1){
    			return t.substr(0, t.lastIndexOf(','));
    		}
    	});

    But note, that will remove any part of any word after a comma. Ify ou could provide a link to a page you are trying this on, I can take a look and possibly provide a better solution.

Viewing 1 replies (of 1 total)
  • The topic ‘Problem with title_divider’ is closed to new replies.