Support » Plugin: Thin Out Revisions » Problem with TinyMCE since plugin update

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author blogger323

    (@blogger323)

    Hello,

    As you mentioned, I switched between Text and Visual on the Edit Post page, but I couldn’t replay that.

    Is it really caused by TOR? What happens when you disable TOR?

    If I disable TOR, it works fine again (and it used to work fine on previous versions of TOR, but broke when I updated it to 1.8.1). If the problem doesn’t occur for you, it sounds like it may be a conflict with certain WordPress themes – 3clicks being one).

    Plugin Author blogger323

    (@blogger323)

    Any error message in your JavaScript Console? With Chrome, use the keyboard shortcut Command – Option – J (Mac) or Control -Shift -J (Windows/Linux) to open the console.

    If you could identify what conflicts with TOR, it would help me a lot. It might be between another plugin and TOR.

    A theme you mentioned seems not free, and I can’t try it…

    See my first comment for JS error on Firefox. Also tried on Chrome and got:

    Uncaught ReferenceError: switchEditors is not defined (line 423 of wp-admin/post.php)
    Uncaught ReferenceError: _wpRevisionsSettings is not defined (line 1085 of wp-admin/load-scripts.php)

    I tried deactivating all the plugins, checking that the visual editor worked (it did!) and then running TOR just on its own (which broke the visual editor again). Therefore, the conflict isn’t between another plugin.

    I appear to have made a breakthrough!

    It seems that version 1.8.1 of TOR doesn’t play nicely with certain themes on earlier versions of WordPress. I’ve updated a number of websites today to WordPress 4.1 (from 4.0.1) and the editor is now working perfectly again!

    Hopefully this helps if anyone else experiences similar problems. 🙂

    Plugin Author blogger323

    (@blogger323)

    Thanks for your information and testing. And sorry for missing your post details. I’m happy to hear that you resolved it by the WordPress update.

    If you could give me a name of failed themes, available for free, I will try to find workarounds.

    Anyway, I’d like to mark this topic as resolved.

    Plugin Author blogger323

    (@blogger323)

    It seems I can replay it on WordPress 4.0.1. I will try to find a root cause. Thanks!

    No worries, glad the information helped. 🙂

    Plugin Author blogger323

    (@blogger323)

    Resolved in version 1.8.2.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problem with TinyMCE since plugin update’ is closed to new replies.