Support » Developing with WordPress » Problem with Tinymce Editor

  • First of all, hi everybody because i am a newbiee of this forum and sorry for my bad english

    Now my problem:
    I’ve installed version 2.0.5 of WP with default editor.
    I’ve tried to update the htmleditor (tinymce) to the last version of the editor (2.0.9), but after update i can’t view the button added to the editor by buttonsnap class (ex. Subscribe2).
    I’ve tried to update the buttonsnap class to the last versione, but nothing change…i am not able to view additional button.

    How can be solve, without update WP to version 2.1?

    Thanks and bye.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Why have you installed 2.0.5 – it is old and insecure and if you keep it you will be back here in two months asking how people are able to hack your site every day even after you change all your passwords.

    If there is a valid reason not to update to 2.1 then at least update to 2.0.8.

    As for viewing the new button try clearing your browsers cache.

    We have tried to update to TinyMCE too and it didn’ work (nothing shows up). Then we were told that it only works correctly in IE. They said it was a problem with Safari and FF, but that makes no sense because Safari and FF have no problems with WYSIWYG editors in other software…

    Hmmm. I updated to the latest version of TinyMCE on another site I did (not WP) and it seems all html code generating issues are gone and it runs smoothly in IE/FF. Maybe you’ll just need to update the TinyMCE core files?
    Another long shot is that Moxiecode changed the variable name where the editor is declared for the form where it’s going (uhmm, I hope you’re following)
    It’s looking something like this in my (non WP) files:

    // deprecated
    // mode : "specific_textareas",
    // new
    		mode : "textareas",
    		editor_selector : "mceEditor",
    		theme : "advanced",

    This code goes where the texterea is which should be replaced with the Editor.
    I’ll give it a go in a wordpress installation and let you know.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problem with Tinymce Editor’ is closed to new replies.