Support » Fixing WordPress » Problem with TinyMCE and Visual editor

  • Hi,

    When I try to add/edit a post, I can’t select the visual editor. In the JS console, I can see this error:

    Uncaught Error: Could not find control by type: wplinkpreview in the file wp-includes/js/tinymce/tinymce.min.js?ver=4603-20170530

    I can solve the problem by downgrading to WP 4.7.5, but if this is a known problem and I can fix it on WP 4.8, it will be the best 🙂

    Thank you for your help.
    Benjamin

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    It is not a known problem, and that’s the first report of it as far as I can find out of almost 8 million downloads, which leads me to believe it’s a conflict with a plugin or theme function.

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Seventeen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    I am too getting this error, in addition I am getting:

    Failed to load plugin: wordpress from url http://dev.bistrotrento.cz/wp-includes/js/tinymce/plugins/wordpress/plugin.min.js

    and

    Failed to load content css: http://dev.bistrotrento.cz/wp-includes/js/tinymce/skins/wordpress/wp-content.css?ver=4.8.2

    It’s on clean installation, version 4.8.2, all plugins deactivated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Problem with TinyMCE and Visual editor’ is closed to new replies.