WordPress.org

Support

Support » Themes and Templates » Problem with theme preview

Problem with theme preview

  • For some reason, I can’t seem to preview themes from my dashboard. I click on the theme, but the only option that appears is “activate” – there’s nothing popping up to show a preview. The only theme that has a preview is the one that I’m currently using. I also have a theme preview plugin, but when I type the supposed URL for the preview, nothing shows up. Any ideas?

Viewing 10 replies - 1 through 10 (of 10 total)
  • I can’t preview certain themes like amazing-grace and blue-grace, while others are distorted with different background and font colors.

    I have the same problem as Layofflist, I wonder why support isn’t answering these inquiries. Also, this problem started after I updated to 2.7.1.

    I have this problem as well. Started after 2.7.1

    Ditto. Same problem. JUST installed 2.7 and could see theme previews. Installed 2.7.1 about a half hour later and BAM! No preview!

    Found this in another thread:
    http://wordpress.org/support/topic/243553

    The bug is in the file wp-includes/theme.php. There are two places in that file where you can find this string:
    '|[^a-z0-9_.-/]|i'
    To fix this problem, change both of them to:
    '|[^a-z0-9_./-]|i'
    (The only difference is the location of the hyphen character).

    Thank you chadparry for that fix. It absolutely made it work.

    Changed to ‘|[^a-z0-9_./-]|i’ but am stil having the same problem: No previews and only the default theme activates correctly. Appreciate any sggestions…

    I’ve got the same problems, dont worry though it wont affect the performance of the actual theme when you activate it.

    Uploaded a picture to my site, which does’nt show up either. But the comments I wrote to it shows. It made me think of my themes: I think the actual problem is that the images that go with the thems don’t show. (And yes, the images folders are in the right places: /public_html/xxxxx/wp-content/themes/dark-smoke/)

    I guess the problem with the themes has something to do with showing/uploading pictures.

    Any ideas…?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Problem with theme preview’ is closed to new replies.
Skip to toolbar