WordPress.org

Forums

Google Language Translator
[resolved] Problem with the new update (18 posts)

  1. peopleinside
    Member
    Posted 8 months ago #

    The look of the flag in the new update is problematic. I can't use in this way this plug in. Please provide a check box in the settings to disabled the new tag css it's orrible with my theme.

    :-( I have to go back for now to the old version.. bleah :(
    Please let choose this with an option in the menu so i can turn off this.

    http://s5.postimg.org/6zirigxmf/screen.png

    https://wordpress.org/plugins/google-language-translator/

  2. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    Hi peopleinside,

    Please refresh your page or browser, and also save the settings once or twice. And make sure you have version 4.0.3 downloaded.

    Your display should look correct again.

    If it does not, please post here again.

    Here's the link to the previous version - but the most current should work.

    http://downloads.wordpress.org/plugin/google-language-translator.4.0.2.zip

  3. peopleinside
    Member
    Posted 8 months ago #

    Sorry, done but not work. Maybe the css edit has changed how the flag are showed and looks bad on my theme.

    This is a problem because before all work fine now no.. very bad look for the flag.

    Now after you change my theme put bad simbol before the flag. Should be a check box in the settings to disabled what you have added to css for done this :S

    Here is what's look like after refresh page cleared chache and saving settings many time:
    http://s5.postimg.org/z0wsw62wj/image.png

  4. peopleinside
    Member
    Posted 8 months ago #

    List of flag is the problem. You have sended bad update :(

  5. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    Hi peopleinside, ok I think this will work. Your theme is overriding some of the plugin styles, and this did not matter in last version because we had not yet added new HTML code.

    Try adding this to your CSS overrides box in your WordPress Dashboard located in "Settings > Google Language Translator"

    #flags li {
        float:left !important;
        padding:0 !important;
        background:none !important;
        border:none !important;
        list-style:none !important;
    }

    Let me know if that does the trick.

    In the next update I will simply force these styles harder, so that you don't have this issue in the future.

    I'm sorry for the inconvenience.

    Rob

  6. peopleinside
    Member
    Posted 8 months ago #

    This not solve the problem, tested and is the same.
    I never had this issue with vwersion 4.0.1 so you have changed something.. who make the new plug in not work.. very sad.

  7. peopleinside
    Member
    Posted 8 months ago #

    I have tried to install the version 4.0.2 and the problem start from this version. So i have resumed 4.0.1

    I can't belive an update will broken the look and the work of the plug in.. fortunatly i update only one website so i took old version frm other website.

    If some day ago when i discover this great plug in i

    was installing 4.0.3 for sure i have removed after few minutes.. it's a bad look.. work great with old 4.0.1 version.. so somthing change in not good way.

  8. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    Hi peopleinside,

    Would you be able to provide a link to your website? I have fixed 100% of issues so far for this problem - there is a theme style overriding the updated plugin.

    To send outside of this forum you can contact me here directly:

    http://www.wp-studio.net/contact/

    I'm sorry for the issues - but if you are going to update this plugin in the future you might want to let me help.

    Thanks, Rob

  9. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    OK, I have found your website -

    If you would like me to solve this issue I will need you to disable plugin that is blocking me from inspecting your page code. And then I would need you to install the most updated plugin - version 4.0.3.

    Let me know if I can help you.

  10. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    I can also see that version 4.0.1 is not fitting inside of your widget correctly. Notice the blue area above the translator.

    Your theme is overriding some of the styles in the plugin. I will fix if you would please allow me to help.

    Thanks! Rob

  11. peopleinside
    Member
    Posted 8 months ago #

    Yes I know but is better look than the new version. I hope to not have to stay with an old version. How can you help me? I'm here..

  12. peopleinside
    Member
    Posted 8 months ago #

    Ok so I have to alow right clic and also I have to install the 4.0.3 and keep for this time whit wrong look. Done you can check. I will wait. Thanks for the help.

  13. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    OK checking now.....

  14. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    Hi peopleinside,

    It appears your theme has some very unique styles placed there.

    Your designer of your theme has applied a background to list-items in your sidebar - so that is why the list of flags has that background image.

    The reason this did not happen before is because the flags were not setup as an actual list, hence your theme did not apply the background.

    Add this to your theme CSS Overrides box in "Settings > Google Language Translator":

    .art-block #flags ul > li:before {
        content:none !important;
    }
    
    #flags img {
        margin:0 !important;
    }

    I was testing directly by using browser tools, so I could be mistaken in this working, but I'm 90% sure it should work.

    Also, your widget is not wrapping around the translator correctly. I think there is incorrect placement of code somewhere in your sidebar area. I will check now to see what I can find.

  15. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    peopleinside,

    The code on your site looks good for the most part.

    Can you tell me the method you used to place the widget in the sidebar?

    1) Did you place the "Google Language Translator" widget into your sidebar?

    OR

    2) Did you use a text widget? By text widget, I'm asking if you dragged/dropped text widget into your sidebar, then placing [google-translator] shortcode inside of it. Is this how you did it?

    OR

    3) Or did you place the translation widget in a file somewhere?

    Let me know and I will try and solve this issue as well.

    Rob Myrick

  16. peopleinside
    Member
    Posted 8 months ago #

    Hi Rob,
    this last code works and now seem to have good look.
    for the widget is placed by the "Google Language Translator" and the background color issue there are only if the zoom up widget stay up to the Google Translator, if i put the Google Translator first it look good but i prefer to have in second position and no matters if background is as are now.

    The important think is all work fine and now looks well.
    Many thanks,
    sorry, many trhouble with the new last two update.
    *Mark*

  17. peopleinside
    Member
    Posted 8 months ago #

    Now it same to work all fine.
    I remove and reput zoom .. i move some widget and now works after putting your css code. thanks ROb, very kind and thank you for the patience with me!

  18. Rob Myrick
    Member
    Plugin Author

    Posted 8 months ago #

    No problems friend! I could totally understand your frustration - that was a very specific CSS conflict, and not normal by any means!

    That is why I always want people to share their website link from the start, so that I can actually see the code. Otherwise, at best I can only guess.

    Thanks!

Reply

You must log in to post.

About this Plugin

  • Google Language Translator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.