Support » Plugin: TablePress » Problem with the drop down menu

  • Resolved worldwade

    (@worldwade)


    Hi,
    Thanks for the plugin, man.
    shortcode: [table id=6 responsive="scroll" datatables_columnfilterwidgets=true /]
    The dropdown menu prints the selection, it’s weird.
    How can I fix that? Thanks!

    • This topic was modified 1 month ago by worldwade.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    Do you mean the items that appear below the dropdowns? That’s expected. This way, when clicking on them, you can remove them again from the filtering.

    Regards,
    Tobias

    worldwade

    (@worldwade)

    Oh ok, is there a way to disable that? And just use the normal drop down menu?

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    you could add this to the “Custom CSS” textarea on the “Plugin Options” screen of TablePress:

    .dataTables_wrapper .filter-term {
    	display: none !important;
    }

    This will hide these words. However, you’ll then not really be able to return to the original state of the table, without a page reload.

    Regards,
    Tobias

    worldwade

    (@worldwade)

    Oh I see, thanks for the answer again.
    Is there any way to put a kind of cross (x) before each item label that appears below the dropdowns? So people understand?

    worldwade

    (@worldwade)

    OK I managed to do the x thing, but I have just realized I have a bigger problem: the dropdowns don’t filter at all?
    https://moroccoultimateguide.com/private-tours-morocco/
    I couldn’t figure out what causes this, and I’m ashamed to say I don’t even know if they worked at all.

    my (current) shortcode:
    [table id=6 datatables_columnfilter=true datatables_columnfilterwidgets=true datatables_columnfilterwidgets_exclude_columns=1,4,5 datatables_columnfilterwidgets_max_selections=1 responsive=”scroll” /]

    worldwade

    (@worldwade)

    Found the solution: “Enable the visitor to filter or search the table. Only rows with the search word in them are shown.” must be selected. My bad.

    Thanks again for the plugin!!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    nice addition to the items! Good to hear that it’s working now!

    Best wishes,
    Tobias

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.