Support » Fixing WordPress » problem with tags count

  • Resolved stanlozoga

    (@stanlozoga)


    I have some posts that are hidden on my site.

    When I look at the posts in the admin I see they have their correct tags.

    When I look at tags list a lot of tags show zero post.

    As the zero is a link, when I click the zero all posts with the tag are shown in a list !!!!

    Is it possible to rebuild the database ? Or correct the counter ?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    The posts should be appearing for you since you’re logged in as an Administrator, that’s expected.

    Can you see the posts by clicking the 0 when logged out, like a normal visitor?

    Overall, the 0 is correct, because it only counts publicly published posts.

    Thread Starter stanlozoga

    (@stanlozoga)

    All posts are public.

    When I browse the site like a normal visitor the tags cloud show only tags higher then zero so a lot of tags are hidden. If I enter manually the url in the browser I can see the posts.

    When I am logged in the admin module I see that some tags have a counter of zero and if I click on the zero I see the corresponding posts in the list. All of them are public.

    Any ideas?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Are you using any sort of caching plugin, or do you see a “Clear/Purge Cache” button in your Dashboard or admin bar? If so, would you please try clearing the cache?

    Note: You do not need to install a caching plugin at this point just to clear a cache you don’t have. If you don’t have a caching plugin or a way to clear a server-level cache, just say so. 🙂

    Thread Starter stanlozoga

    (@stanlozoga)

    No. Not any cache plugin added.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Are the posts in question made by a plugin or using a custom post type of any kind?

    Thread Starter stanlozoga

    (@stanlozoga)

    No. It is all old human being created posts.

    And old. All tags that show the problem have not been used for years. I mean no other posts with these tags for years. May be this can help, or not !

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, yeah that is hard to tell then. Can you provide a link to one of the tag listings on the _front_ of the site which shows as 0 on the back?

    Thread Starter stanlozoga

    (@stanlozoga)

    We’ve finally by hand created new tags and changed posts one bye one. This way the newly created tags show the correct counter and these tags are now shown in the tags cloud.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘problem with tags count’ is closed to new replies.