Support » Plugin: Relevanssi - A Better Search » Problem with tags

  • Quick pre-sale question. We have installed Relevanssi on our staging site and so far love the results with one exception; when the plugin is activated all site tags break… When clicking on a tag, a blank “Posts Nothing Found” page renders. If the plugin is deactivated, all tags go back to working as they should.

    We are loving the Relevanssi search functionality and plan on buying a premium license once we get the tag issue resolved.

    Any ideas what might be causing the conflict with the plugin and our tags?

    Thanks in advance!

    Brad

    https://wordpress.org/plugins/relevanssi/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mikko Saari

    (@msaari)

    See if this bit of code works for you:

    add_filter('relevanssi_prevent_default_request', 'rlv_fix_archive_kill', 10, 2);
    function rlv_fix_archive_kill($kill, $query) {
        if (empty($query->query_vars['s'])) $kill = false;
        return $kill;
    }

    After update to the latest versions (wordpress and relevanssi), when Relevanssi plugin is active – I have no results when I try to view posts by category or tags. When I disable this plugin – I can see all needed posts. Search results seems work normally.

    Plugin Author Mikko Saari

    (@msaari)

    MAGIKru, does the code above work for you, if you add it to the theme functions.php?

    No, I tried this code, but there are still no results 🙁

    @mikko,

    Sorry for the late reply. I too tried the code and it did not correct the problem… Any other ideas?

    Thanks,
    Brad

    Plugin Author Mikko Saari

    (@msaari)

    Sorry, if that doesn’t work, then I don’t have a solution, I’d have to be able to debug things manually, and so far I haven’t been able to reproduce the problem on any of my sites so I could see what’s wrong.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Problem with tags’ is closed to new replies.