Support » Plugin: Remove CPT base » Problem with subfolder installation

  • Resolved phalancs

    (@phalancs)


    Thanks for this plugin. Unfortunately it does not work as expected. I have an installation in a subfolder. After actuivation for my my CPT the links look correct:

    example.com/subfolder/my-post-without-cptslug

    but they redirect to a broken url:

    example.com/subfolder/subfolder/subfolder/my-post-without-cptslug

    the subfolder is repeated three times. How to fix? thanks in advance 🙂

    • This topic was modified 4 months, 3 weeks ago by phalancs.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author kubiq

    (@kubiq)

    Hi,

    first of all – try new version 4.5 – specially for you 🙂

    But now my question:
    I’m programmer for more than 10 years, but I’ve never used WP in subfolder.
    Why would you do that? What’s the reason or purpose to use subfolder instead of subdomain?
    I’m really curious about that. Please reply 😉

    OMG Thank you so much for the quick reply. I really appreciate your help! Unfortunately now I run into a “ERR_TOO_MANY_REDIRECTS” error.

    I tried saving permalinks and changing to default theme without any plugins. But it still runs into the redirection loop.

    I can provide you access if you want to further look into it.

    Just a quick answer to you question: I just use subfolders for development sites 🙂 /alpha /rc etc. 🙂

    Plugin Author kubiq

    (@kubiq)

    ok, probably you have different ports configuration on server
    try now – version 4.6
    well, i recommend not to use subdirectories in future 😉

    OMG it works now!!! You are so cool. Thank you so much! You clearly deserver a price and definitely a 5 star rating – which is on it’s way 🙂

    Thank you so much for your time and effort You are my hero! 🙂 Will think about switching to subdomains for staging sites but had problems with slow DNS servers in the past so I switched to subfolders for development.

    • This reply was modified 4 months, 3 weeks ago by phalancs.
    Plugin Author kubiq

    (@kubiq)

    ok, thanks 😉

    Okay, just a quick and humble follow-up question :O 🙂

    Is it possible to make this also work with hierarchical CPT? Currently the parent levels work. But as soon as I try to open a child post it still returns a 404.

    Thanks a lot in advance 🙂

    Plugin Author kubiq

    (@kubiq)

    ok, try 4.7 and check-on new option in settings

    Yes, that works perfectly! 🙂 Thank you soooo much!!!! 🙂

    Just one very last question and them I am silent 🙂 I promise!

    Is it possible to make this also work with a third child-level? :O

    BTW: Are you open to freelance work? :O 🙂

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    BTW: Are you open to freelance work? :O 🙂

    @kubiq @phalancs That’s not a topic for these forums. I have archived that part of the topic and I am closing this too.

    These forums and not for soliciting paid work.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Problem with subfolder installation’ is closed to new replies.