Support » Plugin: AMP for WP - Accelerated Mobile Pages » Problem with speed

  • Resolved ConsiderThis1

    (@considerthis1)


    Hi,
    On my iPhone it takes ages to go from one page to another. I don’t use my phone for the internet, so I was seriously SHOCKED.

    I can see why Google doesn’t put my AMP pages in good positions in Search.

    What can be done to improve the speed?

    If I remove all but two ads, will that help?

    Would it help if I didn’t have the breadcrumbs?

    My AMP pages are SLOW SLOW SLOW. They are vastly slower than my desktop pages.

    Solution????

    Karen Kline

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • AMP pages don’t seem particularly slower to me but they are slow generally for both canonical and for AMP variants.

    There are many potential reasons for the slowness ranging from hosting provider to compression to embedded google ads. My guess is it is the latter of these.

    Your AMP page (actually put a amp/ on the end or you will also get the overhead of a redirect) is just over 0.5 MB so it is relatively small. It gets good pagespeed and yslow scores. It should be fast and definitely under a second to load. You are also using cloudflare and that should make things pretty quick too. On the canonical page you use a caching plugin so cloudflare should be taking some advantage of that when building out the AMP page’s html.

    One thing I notice is you do not have compression turned on within the AMP plugin. You may get a minor improvement by using that. You can do that in the plugin’s admin panel.

    Now do a test here from your closest location using

    https://tools.pingdom.com/

    Now deactivate google ads and see what load times you get. I think the reason is that google ads are triggering this problem

    “The requests for the following URLs don’t fit in a single packet. Reducing the size of these requests could reduce latency”.

    Also try deactivating the caching plugin and then clear caches on cloudflare and test again. It is possible that your caching plugin is slowing cloudflare down. Generally I have found W3 total cache to work best with cloudflare. Then look at excluding other plugins which may be getting in the way. There is a facility in the AMP plugin to deactivate plugins when building AMP pages. You seem to be using quite a lot of plugins and it could be any one of them.

    As an addendum, when I use google page speed insights it is saying server response time is awful = Server response time measures how long it takes to load the necessary HTML to begin rendering the page from your server.

    • This reply was modified 1 year, 8 months ago by frenchomatic.
    • This reply was modified 1 year, 8 months ago by frenchomatic.
    • This reply was modified 1 year, 8 months ago by frenchomatic.
    • This reply was modified 1 year, 8 months ago by frenchomatic.

    Hi,
    Wow, this is interesting. I thought I had all the settings right, but… maybe not.

    Okay, I’m checking into it. By “compression” do you mean “minify”??? I didn’t have that turned on because when I tried to use it with W3 Super Cache it weirded out my site.

    I just switched it on… so I’ll quickly do some Pingdom tests…
    here are the results
    https://off-grid-insights.com/amp-pages-slower-than-desktop/

    Yes… many reasons for slowness. I ran a Pingdom test for both desktop and amp, so there would be a basis for comparison.

    I don’t know what an overhead is in relation to site pages…

    lol re the reduce size things… most of those refer to Google ad stuff. I don’t have a lot of control over that stuff… lol

    I didn’t know I was using a caching plugin. I thought I removed them. The InMotion Hosting techs said the caching plugins, in themselves, added a bit of slowness, so since I was already using Cloudflare it was better not to use a plug in. You can see that my desktop speeds are pretty good, so I think they were right…

    I pay quite a lot for VPS from InMotion, so overall my server times are… not that bad.

    Thank you so much for taking the time to give me suggestions. I learned one very valuable thing… that AMP caching plugin isn’t very costly… I had thought I had to buy PRO in order to get it…

    Thank you SO MUCH !!!

    As an aside, the original material from The AMP project said that AMP pages are supposed to load in three seconds or less…

    I’m thinking that the reason Google search hardly sends me any visitors anymore, is that my pages aren’t fast enough to qualify for AMP…

    OMG
    OMG
    I never had a page load in under a second before. I am beyond happy with the Cache extension.
    Thank YOU so so so MUCH!!!!

    Frenchomatic…
    I haven’t been this happy in AGES.
    Thank you 🙂
    And, thank you AMPforWP…
    Mohammed and Ahmed 🙂
    🙂

    If you are still using W3 total cache to minify use Cloudflare to do that instead. You don’t want to be doing it in 2 places. Cloudflare minification tends to be more robust and cause less issues.

    If the topic is resolved then please mark it in the sidebar as such.

    • This reply was modified 1 year, 8 months ago by frenchomatic.
    • This reply was modified 1 year, 8 months ago by frenchomatic.

    I hated how complex W3 was, and stopped using it some time ago.

    Thank you for your Excellent help re speed.

    Karen

    I marked it as resolved yesterday. Don’t know why that isn’t showing… it sounds as if you can’t see it.

    Plugin Contributor ampforwp

    (@ampforwp)

    Hello @considerthis1

    Thank you for using our plugin and glad that your speed issue is fixed.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problem with speed’ is closed to new replies.