Support » Plugin: WordPress Portfolio Plugin (WP Portfolio) » Problem with Specific Page feature

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi Glennette

    Have you checked the error log by enabling the debug mode?

    Unfortunately there’s no detail here for me to work with, so I can’t do anything. I can only do something with more information, or with access to your site.

    It’d also be useful to know what STW have done to diagnose the issue, and what they looked at.


    Hey Dan! I was thinking that you and STW had a working relationship and could get together and fix the issue. They have a login and I’m fine with them sharing it with you.


    Hi Glennette

    I’m really really busy for the next few weeks… so could you make it easy for me to help you?

    If you’d like some help, please ping me your details via my site: and I’ll take a look. I can liase with STW if there appears to be no issue with WP Portfolio.


    Thanks Glennette, I’ve got your details and had a look.

    The issue appears to be with STW finding a 404 and not finding your page. So there’s an issue with the URL redirection. WP Portfolio is passing the correct data to STW, so it’s either STW or your site not letting STW access the page correctly.

    Kind Regards


    Here is a bit more information on what is happening with Glennette:

    With specific pages disabled images are returned correctly, but when enabled the requests are appended with arbitrary information causing a 404 error because the page does not exist.

    The urls being sent to us are different from the URLS in the listing. Here is an example: is in the directory is what shows in their request history/logs
    > & is being appended to all request with specific pages enabled.

    Hello Guys and Glennette

    Yep, I spotted the filetype= being added to requests, so that should now be resolved as I removed that error from the code.

    Could you verify that this is still happening? From what I can tell, this appears to be working fine now.


    That did it! The images are correct now. Thanks so much!

    That is awesome, thanks Dan.

    Fantastic, I’ll commit the changes into the main build and release it within a few days.

    Thanks for your help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problem with Specific Page feature’ is closed to new replies.