Support » Fixing WordPress » Problem with slash’s after upgrade to 1.2

  • I have just upgraded to 1.2 and now all my posts that contain the character ‘ in them have suddenly now got a forward slash in front of them. So things like “I’ve” now look like “I\’ve”. This was not the case on 1.02. It has only started on 1.2. I first assumed it was magic_quotes being turned on but I have switched this off and it’s still doing the slash.
    The main index page does not have any slashes, but the rss feed’s do, and so do the comments.
    I have tried removing the slash (whcih is present in the actual database entry) manually but wordpress just reinserts it when editted under wordpress so I am assuming that wordpress is doing an addslash or something when it shouldn’t.
    Any idea?

Viewing 15 replies - 1 through 15 (of 28 total)
  • I’m also having the same problem.

    I just noticed I that same thing is happening in my comments.

    The slashes are also in the edit post preview and in post preview instead of a link going to say http://www.thedenverchannel.com/ it goes to http://www.thetrenchcoat.com/wp-admin/%5C%22http://www.thedenverchannel.com/

    I seem to have got the slashes out of my actual posts by editing them in wordpress and just clicking save again. However this has not worked for some things. Like I have a trackback from “swat\’s blog” and no amount of editing will remove the slash.
    As other people are having the same issues I guess that there must definatly be some extra addslashes functions in the code that shouldn’t be there somewhere!

    Moderator Matt Mullenweg

    (@matt)

    Troublemaker

    Temp fix:
    add_filter('comment_text', 'stripslashes');

    Thanks Matt,
    That did the trick for now.

    I’m having it too. applied the temp fix and that seems to be helping.

    I downloaded a few new files from CVS and it appears to solve the problem without the temp fix.

    Sorry to need to have my hand held but do you know which files?

    wp-includes/functions-formatting.php was updated and wp-includes/class-IXR.php was added

    I have had the same problem after upgrading today. The weird thing is that I have the Recent Comments hack installed, and the comments that are displayed show up as they normally would. No problem with the ‘ being a /. But the actual comments in the text of the site do render the ‘ as a / .
    I was able to remedy this by Editing some of the comments, but it is a tedious process.

    I added the new files from the CVS but I’m still getting the slashes in the edit post preview.

    Ok, this time I did a straight out of the box upgrade. Nothing has been edited and I’m still getting slahes in the edit post preview.
    If anyone can help me with this I’ll name my second born son WordPress. (I already promised to name my firstborn 2fargon for helping me with an eraslier issue)

    I have this with Mingus right out of the box, in the comments, not in the posts.

    The posts on the site itself is fine but in WordPress at the Advanced Editing screen under Post Preview I’m getting the slashes and I don’t know how to correct that.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Problem with slash’s after upgrade to 1.2’ is closed to new replies.