Problem with Sitemap (12 posts)

  1. jhoecannon
    Posted 6 years ago #

    I built a new blog 1-1/2 weeks ago. I went to Google Webmaster tools - my site is verified, but it had not found a sitemap. So, I went to my WP-ADMIN area (I have the XML Sitemap plugin installed), went to "XML Sitemap", clicked on it, and it said "Your sitemap was built on August 31, 2009 2:10 PM." "Sitemap" was a clickable link, so I clicked on that, assuming it would take me to my sitemap. I got the following message:

    Error loading stylesheet: An unknown error has occurred (805303f4) http://www.getcheappc.com/25/wp-content/plugins/google-sitemap-generator/sitemap.xsl

    What does this mean? Is the XML Sitemap plugin not working properly? How do I get it to work?

  2. kmessinger
    Forum Moderator
    Posted 6 years ago #

    Actually the XML file is normal but you are missing a style sheet so it isn't pretty.

    Deactive and delete the plugin. Install the newest version from here, http://wordpress.org/extend/plugins/google-sitemap-generator/

  3. Rhand
    Posted 6 years ago #

    Did this work out by reinstalling the plugin or was there another quicker solution?

  4. jinbatsu
    Posted 6 years ago #

    same here..
    but my problem is
    - there is no problem accessing with www, but
    - there is a problem accessing without www

    So, I decided to change the url on my Google Webmastertools using www
    And it's work now.

  5. leet8845
    Posted 6 years ago #

    Thanks jinbatsu, that fixed my problem.

  6. Rhand
    Posted 6 years ago #

    For one site I just had to drop the www in the link @ Google Webmaster Tools and after that it linked to the sitemap without spitting out the .xsl stylesheet issue.

  7. Seth Carstens
    Posted 6 years ago #

    I tried with and without the WWW. The stylesheet error is the only things that's displayed, so its not just "not pretty" but doesn't work at all. Not to mention when you copy the XSL link into the browser it exists... not sure why its throwing an error on a file that exists.


  8. Seth Carstens
    Posted 6 years ago #

    realized it does show up fine in IE meaning the bots probably pick it up fine.

    Also realized it was being stored in the main directory, going to move it to that domains uploads directory and see if it works.

  9. Seth Carstens
    Posted 6 years ago #

    That seems to have fixed my problem. I have a multi domain custom configuration going so the root is not a good place for these files for me.

  10. way2tech
    Posted 6 years ago #

    i have The Same Issue But Successfully Resolved By Me
    Just Add The Following code To Your .htaccess

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^way2tech.net [NC]
    RewriteRule ^(.*)$ http://www.way2tech.net/$1 [L,R=301]

    1.replace way2tech.net With Your Domain Name
    2.Use If Your WordPress site Is Without www Means then Just Use The Following 9 reverse Order )
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www.way2tech.net [NC]
    RewriteRule ^(.*)$ http://way2tech.net/$1 [L,R=301]

    Demo : visit : http://way2tech.net/sitemap.xml
    Or http://www.way2tech.net/sitemap.xml - Brings The Same page
    Hope Its Working Let Me Know By reply Here
    - Thanks

  11. paadalvarigal
    Posted 6 years ago #

    Use relative path for the stylesheet. It solves the problem. Seems access to other domain (with www and without www are considered different domains) is restricted.

    Let me know if it works.

  12. toddbiala
    Posted 6 years ago #


    Can you elaborate on how to use relative path for the stylesheet? I dont understand how to do it. I tried pasting the code that way2tech provided but then received this error:

    Error loading stylesheet: A network error occured loading an XSLT stylesheet:

    Im clueless on what to do to get my sitemaps to work

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.