Support » Plugin: Slider, Gallery, and Carousel by MetaSlider - Responsive WordPress Plugin » Problem With Shortcode to Limit Slideshow to Homepage

  • Resolved SquarePeg61

    (@squarepeg61)


    Some information before I get to a description of my problem:

    WordPress Version: 5.4.2
    Meta Slider Version: 3.16.4
    FlexSlider
    Using With WordPress 2020 theme; haven’t tried other themes
    Disabling Other Plugins: Haven’t tried

    I want the slideshow I created with Meta Slider to only show on the homepage of the site listed above. In reading the FAQ about Meta Slider, I saw that the shortcode to show the slider only on the homepage is as follows:

    [metaslider id=XXX restrict_to=home]”);

    I wrote the shortcode as shown above, substituting the four numbers listed in the How to Use section for the four x’s listed above and reviewed the homepage. All I saw was the following:

    “);

    I then removed those three characters from the shortcode and took another look at the homepage. Nothing showed. I’d welcome any help. Thanks!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi,

    In WordPress, a shortcode is formed within [ and ] so those extra characters are not valid.

    Where are you putting the shortcode? Are you sure you have the correct ID? You should be able to copy the MetaSlider shortcode directly from the settings page (click it to auto copy it)

    Thread Starter SquarePeg61

    (@squarepeg61)

    Hi! Thanks for your response. After I posted my question here, I did some more research and found out it was necessary to add a Meta Slider widget to my list of displayed widgets, which I had not done. I did that and the slider is now showing on the homepage.I’ll mark this as solved.

    Hi @kbat82

    I am facing the same issue that @squarepeg61 faced with my site (www.officeworkspng.com) that I am currently working on. Are you able to assist me resolve this metaslider to ONLY my HomePage instead of the entire site? I have tried the short code without any success. I am using Storefront theme.

    Thank you,

    Ben

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problem With Shortcode to Limit Slideshow to Homepage’ is closed to new replies.