Support » Plugins and Hacks » Problem with SEARCH and calpress

Problem with SEARCH and calpress

  • Hi,

    I have noticed that if you have the callpress plugin installed then a wordpress search with a matching keyword in one of the event saved with callpress will get an error:

    problem Uncaught exception ‘Calp_File_Not_Found’ with message ‘The specified view file doesn’t exist.’
    (plus more stuff after that).

    If you google for the above error message you will see some other sites have the same problem.

    Any idea why this is happening and how to fix it?

    Below is the full error (with the path of my website replaced with WEBSITE_PATH:
    I have noticed that it references a “test event” that does not exist anymore.

    Fatal error: Uncaught exception ‘Calp_File_Not_Found’ with message ‘The specified view file doesn’t exist.’ in /WEBSITE_PATH/wp-content/plugins/calpress-event-calendar/app/helper/class-calp-view-helper.php:65 Stack trace: #0 /WEBSITE_PATH/wp-content/plugins/calpress-event-calendar/app/controller/class-calp-events-controller.php(598): Calp_View_Helper->display(‘event-multi.php’, Array) #1 /WEBSITE_PATH/wp-content/plugins/calpress-event-calendar/app/controller/class-calp-events-controller.php(524): Calp_Events_Controller->multi_view(Object(Calp_Event)) #2 /WEBSITE_PATH/wp-content/plugins/calpress-event-calendar/app/controller/class-calp-events-controller.php(449): Calp_Events_Controller->get_view(Object(Calp_Event), ‘<p>test event M…’) #3 /WEBSITE_PATH/wp-includes/plugin.php(173): Calp_Events_Controller->event_content(‘<p>test event M…’) #4 /WEBSITE_PATH/wp-includes/formatting.php(215 in /WEBSITE_PATH/wp-content/plugins/calpress-event-calendar/app/helper/class-calp-view-helper.php on line 65


Viewing 8 replies - 1 through 8 (of 8 total)
  • Fix it actually…
    2 part fix:
    1) Because I did some tests on my blog before I had a domain name, some of the settings/post meta data were still pointing to the wrong address (although everything looked fine on my website!), I used the technics found here:

    So you need access to your database directly.
    I also did the trick about the permalink mentioned in the above thread.

    But this was still not good enough… it was then complaining with a similar error but saying it couldn’t find an event in the database (event 275).

    After digging around for a while…
    2) I removed a post with an ID 275 in the wp_post table

    Now it works 🙂

    well… I spoke too fast!!
    As soon as I post a new event, and do a search with a keyword used in that event I get the same initial error again!

    bugsland, did you have an more luck with this or have you given up? (I see you are asking questions about “My Calendar” now). I am having the same problem and would like to resolve it and stick with Calpress.

    Hi jknutt,
    I have actually given up indeed and am using the “my Calendar” plugin.
    Although Calpress looks better I needed a calendar plugin ASAP and the fact it broke the search functionality was not an option.

    If Calpress gets fixed I might get back to it, but have to say I like the simplicity of “My Calendar” now. Not as flashy but efficient!

    Plugin Author Aspire2


    jknutt / bugsland – thanks for letting us know and sorry for the slow response. We have a dedicated support desk and do not always check this forum. Especially because it has been a holiday weekend in the US.

    We have diagnosed the issue – what is happening is that when you search it is attempting to return the event. However – the search page is not designed to show the calendar. As a result – there WordPress is generating the error.

    We are looking to resolve this asap.

    In the future – please use our dedicated support desk at https://calpress.zendesk.com/home


    I am not sure if it is possible but it wouold be a great feature if the WordPress search did return results for the calendar as well. That way I wouldn’t have to have 2 different search bars…one for my blog/articles and one for the calendar.

    Thank you for looking into this issue.


    No problem! Thanks for responding and look forward to test a newer version.


    Plugin Author Aspire2


    jknutt / bugsland – free version has been fixed for this issue in our development version


    Also we will update the pro versions later today.

    Thanks, Don

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem with SEARCH and calpress’ is closed to new replies.