Support » Fixing WordPress » Problem with Safari

  • Resolved unklee

    (@unklee)


    I have a static front page, and a summary the latest blogs appear on a blog page. First there is the blog title, then on the left a 300×150 reduced graphic of the featured image, and on the right the summary text. Then repeated fro the next blog post, etc. I do my work on a Mac using Safari.

    Everything has been fine until recently, when the first line of the text appeared over the top of the image, but the second and following lines were where they should be. My guess was that the image was slightly lower down the page and so the text appeared in the gap above the image.

    However on Chrome and Firefox on my Mac, the text is all in the right place, so it appears to be a Safari issue, and only a recent one (I think I upgraded to the latest version recently).

    Is anyone else having any problems like this with Safari? Does anyone have a suggestion to fix it please?

    My thought to fix it is to put a small margin or padding before the text so it drops down level with the top of the image, but making that happen just on the blog page might be tricky, and I am reluctant to fiddle too much with something that has been working fine, and maybe Safari will sort itself out in time.

    Thanks for any thoughts..

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Any ideas please?

    sujal

    (@sujal-karki)

    Hello @unklee,

    I’m working with some colleagues at WordCamp Kathmandu Contributor Day and we are discussing your issue. After reading your queries and viewing your code using developers tools on your site, I would suggest to wrap paragraph using some div and add style as overflow: hidden to that added div. This could solve your issue. If you are still having an issue then please let me know.

    Best Regards

    Thank you so much, I will give it a try.

    Hi sujal, the curious thing is, went I went back to that page, it now appears correctly again, and as far as I can remember I haven’t changed anything. I can’t work out how – e.g. I don’t remember upgrading Safari in the meantime. If you hadn’t seen there was a problem too, I would think I had imagined it. Anyway, thanks for your trouble.

    sujal

    (@sujal-karki)

    Hi @unklee,

    No worries.

    Regards

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem with Safari’ is closed to new replies.