Support » How-To and Troubleshooting » [Resolved] Problem with RSS widget

[Resolved] Problem with RSS widget

  • Hi,

    I want to add a custom made rss feed on my website via the rss widget, but i always get the error “Error: could not find an RSS or ATOM feed at that URL.”.

    Its this rss feed which i want to add: http://www.laptops-vergelijken.nl/productrss/s0.xml

    I have checked the logs to see if wordpress made a http request, but it didn’t. So i’am not sure whats going wrong. I have an other rss feeds on my website which does work.

    I hope someone can help me with this 🙂

    Also 1 more question: where is the cache folder where the RSS is stored?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Are you using 2.7?

    If so, it might be related to these:

    Yes, i’am using 2.7, but i have to say; before i upgraded wordpress i had the same problem.

    Can anyone try adding the feed? That way i know it’s not my wordpress install or host.

    I tried the same rss feed with blogspot and it seems to work :S

    Added it to one of my RSS feed widgets and it seems to work ok. I think the cache is stored in the database somewhere. Looks like it’s stored in the wp_options table. If you edit the wp-includes/rss.php file and look for the init() function, you can turn off the cache temporarily.

    function init () {
    	if ( defined('MAGPIE_INITALIZED') ) {
    	else {
    		define('MAGPIE_INITALIZED', 1);
    	if ( !defined('MAGPIE_CACHE_ON') ) {
    		define('MAGPIE_CACHE_ON', 1);

    Just set MAGPIE_CACHE_ON to “0” instead of “1”. Then try it. If it works, change it back to “1” and it will refresh itself within an hour which is the default cache storage time.


    I removed the cache from the database and set MAGPIE_CACHE_ON to 0, but its still not working 🙁

    Is there any way to figure out why it won’t get the rss file?

    Ok i found out that in http.php line 262 the function:

    $response = $transport->request($url, $r);

    returns this:

    WP_Error Object ( [errors] => Array ( [http_request_failed] => Array ( [0] => connect() timed out! ) ) [error_data] => Array ( ) )

    So its a time out issue !

    I have tried setting CURLOPT_CONNECTTIMEOUT en CURLOPT_TIMEOUT to a higher value, but now all it does is loading loading loading 🙁

    I fixed it by using feedburner 🙂


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Problem with RSS widget’ is closed to new replies.