Support » Theme: Ascend » Problem with product search

  • Resolved danina84

    (@danina84)


    Hi,
    I am using the search icon in my topbar(not main navigation). In the theme settings you can choose to only search for products – but this does not work. vene if you search for a page, you will get a result. could you please check on this? Thank you.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thanks for posting, I’ll update with a fix for this in the next version.

    Ben

    Thank you!

    Hi,
    I have to get back on this: I notice that while the product search is enabled now in the topbar search, the translations that I made with Poeit for the search placeholder as well as for the seacrh result page title do not work anymore. The search placeholder says “Search products”, even though I have translated it in my child theme, and the search results page title is back to the default translation, even though I had changed the title…

    Hey,

    Can you please post a link? Also, in the future it’s best to open a new ticket with all support queries. Thanks!

    Thanks,
    Kevin

    Hi Kevin,
    sorry, I can’t provide a link, but what I mean is the following:
    The regular search placeholder as well as the search page title I can edit in the po file of the theme and it works.
    BUT – the placeholder for the product search which I have enabled for my topbar search as well as my mobile search (because I only want to allow to search for products, not pages or posts), as well as the search page title for this product search I CANNOT change with Poedit – I have found strings that showed for example “Search products” and I have translated them, but still, the placeholder an also the search page title remain in English , see my screenshot: https://postimg.cc/image/pztcxx15d/

    I have also looked in Woocoommerce po file and edited some strings there, but also no change.

    Additionally I noticed one other thing: Even when you have “only product” search enabled, the 404 page still has a search field, and THIS search field is still searching for ALL entries, not only products…

    • This reply was modified 2 years, 1 month ago by danina84.

    1. I believe the issue is that the pot file is not in the latest sync. You should be able to sync the file within poedit or loco translate. In poedit, go to catalog, and update from source code. Then you should be able to find the string in the ascend files. Loco translate makes this pretty simple. Let me know if you’re able to get the file synced.

    2. By default the 404 uses a regular search. You can customize the 404 page in the premium version of Ascend to add whatever search you want. Otherwise with free, you’ll have to find a plugin that allows you to customize the 404.

    -Kevin

    Hi Kevin,

    no, it is not an outdated pot-file…I even tried t with the latest version of Ascend’s pot-file, translate the string “Search products…”, and uploaded it in my child theme. Still, it’s not being translate, while every other translated string works just fine. the ONLY way to translate it is to edit the parent theme file in woocommerce–>product-searchform.php.

    Also, how can I edit the page title and page content of the search result page when “search only products” is enabled? With the regular search(not only products), I can succesfully do it by overriding Ascend’s search.php, but this does not affect the “Search only products” search page.

    Hey,
    1. What Kevin was trying to explain is that the themes pot file is out of sync. You just need to syc it. We’ll have it updated with the next version but in your current version, you will need to update the pot tile. you need to sync it. Loco translate plugin makes this extremely easy to do.

    2. Search only products uses woocommerce archive templates. If you want to override things you have to override how woocommerce controls the archives through the product-archive.php template and that will affect your archives not just your search.

    1. Ah, okay. So you are saying the actual theme pot-file is outdated an you will fix it in the next update. Is this difficult to do with Poedit? I tried updating it from source code like Kevin mentioned but I am getting errors. I am not sure how this would work since Poedit is not on my site, but offline.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Problem with product search’ is closed to new replies.