Support » Fixing WordPress » Problem with Permanent-link structure change

  • Hello,
    at the beginning i have to say that i never did anything related to WordPress/Ubuntu before 1 Month. Now, i have the project for my work to set up our new shop with WordPress. I allready have set up our new dedicated server with Ubuntu 20.04 and all other needed components. I succesfully installed the newest version of WordPress and it was running without problems so far. Unfortunately i encountered the first problem today. I tried to change our permalink-strucutre from “Plain” to “Post name” and after this i get a “404” error everywhere, except on the homepage.

    I thought that was an common problem, and i found many posts about this on the internet. I tried everyhthing(!) that i found in the last few hours, but nothing seems to work.
    Here is what i did so far:

    1) I checked the .htaccess File and all permissions are there

    2) I checked the .htaccess file for the RewriteEngine, everything is correct there

    3) I´ve checked the apache2.conf and AllowOverride=Yes/Require all=granted

    4) I´ve restarted the apache2 service and the whole server

    5) I´ve read that there should be AllowOverride=All too in the 000-default.conf file
    at the sites-available folder but there is nothing in like that. I tried to add the
    following there and restarted everything after this but that hasn´t changed anything

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    I don´t know what to do next, that was really everything i found in the past few hours of research.

    Please apologize my bad english!

    Thank you all so far,
    please stay safe

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.