WordPress.org

Support

Support » How-To and Troubleshooting » Problem with Permalinks; Need Help!

Problem with Permalinks; Need Help!

  • We are using the “POST NAME” structure for our permalinks. When we update the same post after it has been published after several months; we also change the post name at the same time; which effects the web URL at the same time. Whenever someone clicks on the old url; it shows an entirely different post on our blog. Is there a plugin or something that can fix this for us. We are using a plugin called Permalink Finder; but it still does not resolve the problem. Any help or suggestions would be appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Krishna

    @1nexus

    Member

    Reset your permalinks and see if it helps.

    A link to your site will help us understand the problem better.

    Moderator justingreerbbi

    @justingreerbbi

    Forum Moderator

    Seems a bit weird. When WordPress changes the permalinks it does not change the titles or anything and works right away.

    Are these links something that are added into the content via the editor or even set in the links section?

    Reason I ask if because these links I am unsure if they changed as well with permalinks are changed thus resulting in a error.

    We just change the post name in the editor section including editing the permalink name to match the new post title. What is so weird is that just a couple of our posts that we redone; whenever you click on the old url address; it shows a totally different post on our blog. Most of the other posts that we redone show correctly to the new url address.

    Moderator justingreerbbi

    @justingreerbbi

    Forum Moderator

    It just may be that you are going to have to change all the posts if you are using new urls.

    If you change the permalink structure all your old links are no good no more.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem with Permalinks; Need Help!’ is closed to new replies.
Skip to toolbar