WordPress.org

Forums

BulletProof Security
[resolved] problem with permalinks (7 posts)

  1. G-Olly
    Member
    Posted 1 year ago #

    Hi there,

    I am having a problem with my permalinks. The permalink structure that I have for my posts is - Month and name (common setting.

    The site is an international/multilingual site using WPML. I also have bullet proof security installed, latest versions of each. Secure .htaccess is enabled and htaccess is writeable.

    When I create a post the month and name setting works fine, inputting the correct values i.e. mysite.com/2014/03/sample-post/

    Now when I try and make a correction and update the post the permalink changes to mysite.com/-0001/11/sample-post/ - meaning the post can no longer be found.

    BPS then alerts me that the site is no longer protected by the latest version even though it is.

    I do not know why this is happening - I am thinking there might be a conflict between WPML and BPS playing havoc with my permalinjk structure.

    Any help would be much appreciated.

    Many thanks,
    Olly

    https://wordpress.org/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    The only WPML issue/problem that we are aware of is this one: http://wordpress.org/support/topic/problem-with-wpml-1?replies=4

    If BPS is alerting you that your site is no longer protected then something is changing your root .htaccess file. Most likely it is the cPanel broken HotLink Protection Tool problem: http://forum.ait-pro.com/forums/topic/read-me-first-free/#cpanel-hotlink-protection
    or the WordPress flush_rewrite_rules() function problem: http://forum.ait-pro.com/forums/topic/read-me-first-free/#flush-rewrite-rules

    Both of these known issues/problems are solved by locking your root .htaccess file.
    1. Click the AutoMagic buttons and activate Root Folder BulletProof Mode.
    2. Go to the htaccess File Editor tab page and Lock your root .htaccess file. AutoLock should also be turned On.

    The permalink URL change is something new that no one has ever reported before so you may have a combination of issues/problems happening that may or may not be related to BPS and may involve or be caused by another plugin or something else.

    Check your BPS Security Log and post a log entry that looks related to this issue/problem. There may not be a log entry for this type of issue though.

  3. G-Olly
    Member
    Posted 1 year ago #

    After playing around with publishing posts and updating etc. I have come to the root of the problem. It seems that it's a problem with WPML not BPS in anyway. Thanks for replying. I will keep you posted as to my progress.

    Many thanks,
    Olly

  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like this is a known issue/problem in WPML where the year gets changed to -0001.
    https://wpml.org/forums/topic/year-replaced-by-0001-when-updating-a-post/

  5. G-Olly
    Member
    Posted 1 year ago #

    Thanks AIT, I am in contact with the WPML guys. As you say this looks like a re-occurring issue. I hope I can get a solution before to long.

    Thanks again,
    Olly

  6. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Resolving thread - Known issue/problem with WPML and not a BPS issue/problem.

  7. G-Olly
    Member
    Posted 1 year ago #

    Yep all good, thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags