Support » Installing WordPress » Problem with path?

  • I just tried running install.php and it’s not working (the usual problem) — yes, I downloaded all the files, and I changed the items in wp-config.php that needed changing.
    So, this is the error I see:
    Fatal error: Failed opening required '//wp-settings.php' (include_path='.:') in //wp-config.php on line 31
    What the heck is this? And how do I fix it?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Mark (podz)


    Support Maven

    Have you searched here for ‘//wp’ and checked out anything in those threads ?

    Sure have. I guess I should’ve taken the clue that no one has been able to fix it for other people…posts going back to last November with this problem keep noting “Hey – you’ve got one too many slashes! Fix that!”
    As helpful as that may seem, those of us having this trouble have only changed the parts of the code in wp-config.php that you’re told to change. I don’t know php, and my only thought is that ABSPATH is being misdefined somehow.
    So – for someone who knows php – how do you get a script to print out the value of a string? Then I can see if the problem is ABSPATH.
    Btw, this is the one changed I’ve tried so far:
    old code:
    define('ABSPATH', dirname(__FILE__).'/');
    new code:
    define('ABSPATH', dirname(__FILE__));
    thinking to get rid of that final /
    but no, that didn’t work.
    So heck if I know.

    Maybe it’s the version of php I’m using.
    I changed ABSPATH to the actual path as opposed to using the dirname function. But now I’m getting weirder problems:
    Fatal error: Failed opening required ‘ABSPATHwp-includes/wp-db.php’ (include_path=’.:’) in /nfs/cust/3/46/35/53643/web/wordpress/wp-settings.php on line 30
    For some reason, ABSPATH isn’t being passed along to wp-settings.php. Seems to me the php is all screwed up. So I’m going to copy the define line over to that. But this does not bode well at all. It may end up I’ll have to find a tool other than WordPress, because I don’t want to comb through all the scripts to make sure they work. The whole point was for it to be easier to use, and faster, than other tools.

    Finally! I get the failure to connect to database error! That’s fine, because I’m not sure if my database has really been activated. I told my host just yesterday to activate it, but maybe it’s not done yet.
    Ok, I guess I’ll try again in a couple days. Still, I don’t like that the php isn’t working quite right. That really doesn’t inspire me with confidence that this is going to work for me if I do manage to get it installed.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem with path?’ is closed to new replies.