Support » Plugin: HumanCaptcha by Outerbridge » Problem with non-English characters?

  • Hello! My personal website has some traffic but really few comments. I have secured it against malicious activity with Akismet, iThemes security and other measures. I’ve dumped obvious comment spam so I don’t have to review it but still get a dozen spam messages in comments every month. They’re not published of course. I’ve used solutions like yours in other WordPress-sites on forms and really like the possibility of setting up your own questions for spam protection. I use Finnish because my content is in Finnish. HumanCaptcha seems to have some trouble with this. I have a dozen questions and answers set up and tested the solution. Most of my questions have Scandinavian characters in them (ä or ö). This seems to be a problem to HumanCaptcha. Only when the answer to the question is numeric and correct the comment is accepted. (Yes, I have made sure the case is correct, there are no misspelling on the answer in settings or in comment form and checked that there are no extra space in the Settings answer.) If the question doesn’t have Scandinavian characters all correct answers are accepted. Can you confirm this is the case and can you fix this in reasonable time?

    While testing I noticed also one time the question wasn’t inserted in the comments form and that I can’t update the questions. I can delete and create new questions but when I make corrections or changes to the questions and press Update the question resets itself to the original form.

    As development suggestion I would hope that the case-sensitivity would be optional so that simple lazyness wouldn’t make the answer incorrect.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Outerbridge

    (@outerbridge)

    Hi
    I think I’ve spotted the problem. Can you test v3.1 when it’s available and let me know how you get on please?
    Many thanks!

    Do you have an estimate on when it will be available? I’ll be happy to try it out.

    Plugin Author Outerbridge

    (@outerbridge)

    Hi. I released the update a couple of days ago. 🙂 Please let me know how you get on…

    Sorry, hadn’t signed on to my site. 🙂
    Updated the plugin. Tried to make sure the questions and answers are correct by pressing Update on them but it could not update them. Tried with Firefox and alternate email on three different articles. Got two different HumanCaptchas with and without letters like ä. Got error on all answers (all definitely correct) – none of which were numerical btw.
    So no relief from that update.

    Plugin Author Outerbridge

    (@outerbridge)

    Hi.

    That’s strange because the update fixed the problem for me – I was testing using the “ä” character that you mentioned.

    It might be that there’s a problem with the encoding/collation in your MySQL database. Can you check the “{your_prefix}obr_humancaptcha_qanda” table in the database please? You can use phpMyAdmin in your hosting to do this. For example, I have a test site which uses “UTF-8” and “utf8mb4”. You need to check the table and the individual columns as well.

    Please let me know what you find…

    Quite a brothel there:
    phpMyAdmin reports server character set as UTF-8 Unicode (utf8)
    Connection Character Sets utf8mb4_swedish_ci and therefore probably about half of the tables are the same. Some are utf8mb4_unicode_ci but a bit less than half, including obr_humancaptcha_qanda and it’s fields are utf8_general_ci.
    Coming from long Joomla background this amazes me and makes me wonder why there aren’t more problems with this kind of things.

    Btw, let me check something: you are using the actual ä character, not doing ¨ + a? The ä and ö are characters on they’re own, not a and o with ¨.

    Testing the plugins working further gives mixed results. Now I’ve seen also correct answers to questions with scandinavian characters in the question accepted. The false negatives (correct answers rejected) seems random now.

    I checked the conversation about cache on the forum and have now temporarily disabled WP Super cache to make sure it’s not intervening. Still not consistent and reliable results.

    Plugin Author Outerbridge

    (@outerbridge)

    Hi

    In answer to your question, yes, I used the ä character. The mixed character sets could be a result of the way your hosting works – my plugin uses the defaults that are set for the database. You might want to trying changing the encoding/collation – but make sure that you take and verify a backup first!

    I’d say that this is pretty unusual and not typical of WordPress. As I often say to my customers, the upside of WordPress is that it’s flexible, and the downside is that it’s flexible.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem with non-English characters?’ is closed to new replies.