Support » Plugin: Autoptimize » Problem with NK Sliding Panel after Optimize

  • Resolved haidepzai

    (@haidepzai)


    Hi,

    please take a look on the contact form on the right side.
    I don’t know what happened but now I just see squares!
    I did some Optimize with Autoptimize, W3 Total Cache, Hummingbird and Async Javascript but for some reason I have this problem now.
    After deactivating all of the aboves plugins, I still have that problem.

    What can I do?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    some tips:
    * using 4 optimization plugins is too much, start with one and make sure it works perfectly before even considering adding another
    * AO, Hummingbird & W3TC all 3 can do CSS/ JS optimization, make sure only one of those is doing CSS/ JS optimization to prevent conflicts
    * Hummingbird & W3TC both do page caching, you should only have one to do so.
    * if the problem persists when all 4 are disabled, then you likely have a page cache (at your host?) that needs to be purged

    I already did and purged cache…
    I did inspector tools and see there is a problem with the font-family “font-awesome”
    If I delete the !important it will show up again.
    For some reason only certain pages have this bug other pages works fine and the icons of font-awesome is shown.
    So I guess some pages have some conflict with the font, I am not sure.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, in that case we at least know the issue is not related to your speed-up experiments šŸ™‚

    I’m pretty sure it has to do something with this css file (autoptimize css)

    Before

    After

    How can I access this css file?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Iā€™m pretty sure it has to do something with this css file (autoptimize css)

    but you wrote earlier the problem remained even with AO disabled?

    How can I access this css file?

    it is automatically generated by combining all of your CSS, to changing a single file is rather useless as it will get replaced by another sooner or later which you would again need to change.

    what you’ll have to do is ensure it works when AO is disabled (which it does not now, as confirmed by loading the same page with ?ao_noptimize=1 added to the URL).

    If I were you I would start with disabling all optimization plugins (I still see Hummingbird, Async JS & I think W3TC active) and see if your FA-icons appear. Then start by adding 1 plugin and see if it still works. If that one plugin is AO, I’ll be happy to guide you šŸ™‚

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.