Support » Plugin: W3 Total Cache » Problem with new update

  • Hello makers of the W3 Total Cache Plugin,

    After today’s update, my website didn’t work anymore. I didn’t see the menu’s and design but only text. After deactivating your plugin, the problem was solved. So something seems to go wrong with this update.

    Kind regards,

    Imke Wijnhorst
    Stichting Gezinsfundament

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    Can you please re-enable the plugin, disable minify (if enabled) and purge all caches. see if the issue persist.

    Dear Marko,

    We are also running into an issue, i am not sure if it’s update related however. In our case the blog -> edit.php and post-new.php pages show a white screen. Other pages don’t have problems. Quite a lot of Uncaught ReferenceError: _ is not defined etc. Any thoughts?

    Much appreciated

    Kind regards,
    Tjerk

    My website has stopped functioning partly. I’m getting HTTP 500 error or Internal Server Error. The homepage is online but internal pages show the error message or photos are not loading. I cannot log in to the site. It started with wordfence giving me a warning that two plugin updates contained malware but warned that might be a false reading. I deleted the flagged file on the first plugin and then the white screen came up. The plugin was W3 total cache. Can you help?

    Hi Peter. I’m not a dev for this plugin but, if you simply deleted files from an update then you’ve probably done yourself a disservice. You’ll have to ftp in and delete the plugin folder itself.

    @vmarko Dear Marko, please ignore my previous reply. Problem has been solved and it was not W3 Total Cache Plugin related. In our case, if anyone has the same issue, it was the following code in the theme:

    function defer_parsing_of_js ( $url ) {
    if ( FALSE === strpos( $url, ‘.js’ ) ) return $url;
    if ( strpos( $url, ‘jquery.js’ ) ) return $url;
    return “$url’ defer “;
    }
    add_filter( ‘clean_url’, ‘defer_parsing_of_js’, 11, 1 );

    Dear Marko (@vmarko),

    Thanks for your response. After doing as you told (re-activation, dis-abeling minify and purge cache), the problem is gone. So thank you. But why does the plugin have the minify function if it doesn’t work?

    Kind regards,

    Imke

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello all and thanks for your updates.

    @peter49133079 Wordfence can sometimes give a false positive result on malware. Especially regarding W3 Total Cache. W3 total cache does not contain malicious files and what Wordfence mostly refers to is contentGrabber.php which part of the code is required to add dynamic content.
    If you know which file you have deleted you can replace it by downloading W3 Total Cache from here and simply copy the file via ftp to /wp-content/plugins/w3-total-cache.
    If you don’t know which file you have deleted, you need to manually remove W3 Total Cache and re-install it. you can use this article here

    Ok. Thank you. Problem solved. I took the advice of wordfence to delete the file without realizing that this would cause a problem.

    • This reply was modified 1 month, 3 weeks ago by  peter49133079.

    Hi there,
    my website also stopped working (blank pages only). I disabled the minify function and now it’s working again. But will there be a bug fix coming soon, so I can re-enable minify? Thanks in advance.

    Edit:
    I don’t use Wordfence and didn’t delete anything. I just updated. I do use All in One WP Security & Firewall alongside W3TC though – so far without any issues.

    • This reply was modified 1 month, 3 weeks ago by  Kenika.
    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @kenika,

    There is no known bug for us to fix. Is minify enabled on auto or manual? What settings do you have enabled in Performance>minify?
    Have you tried deleting the /wp-content/cache/minify folder?

    Thanks for your quick reply.
    It’s set on auto.
    I just deleted the /wp-content/cache/minify folder: didn’t solve the issue.

    What settings do you have enabled in Performance>minify?

    Sorry, I just can’t find the “Performance” menu…?

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    It is in the toolbar on the left of your dashboard.
    See the attachment https://i.imgur.com/Sco8VuQ.png

    Ah, sure. Sorry, I renamed the Performance menu to “W3TC”. ^^

    Settings that I activated:
    General
    – Rewrite URL structure
    – Minify error notification: Admin Notification
    HTML & XML
    – Enable
    – Inline CSS minif.
    – Inline JS minif.
    – Line break removal
    Ignored:
    – google_ad_
    – RSPEAK_
    JS
    – Enable (Non-blocking using “defer” before </head> and after <body>
    – Minify: Preserved comment removal + Line break removal
    CSS
    – Enable
    – Preserved comment removal
    – Line break removal
    Process
    Advanced
    21600 sec.
    86400 sec.
    several pages at “never minify the following pages”
    one script at “never minify the following JS files”
    Include ext. files/libraries: https://ajax.googleapis.com

    That’s it. Gotta go to work now, but will reply asap. Thanks again!

    • This reply was modified 1 month, 3 weeks ago by  Kenika.
    • This reply was modified 1 month, 3 weeks ago by  Kenika.
    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @kenika,

    Try to disable the settings one by one, HTML minify, JS and then CSS and see which one is causing this.

    Hi Marko,
    it’s HTML & XML minification that causes the problem. Any idea how I can fix this?
    Thank you very much!

    • This reply was modified 1 month, 3 weeks ago by  Kenika.
Viewing 15 replies - 1 through 15 (of 37 total)
  • You must be logged in to reply to this topic.