Support » Plugin: Attachments » Problem with new lines in caption textareas

  • Resolved jbx

    (@jbx)


    If I set the caption field for attachments to textarea (as shown in the example) newlines are not handled correctly.

    When I edit the post again instead of new lines I get \n (not the line-break, an actual backslash and letter n showing in the textarea). This is confusing users (editors managing attachments).

    Is there a way to fix this?

    http://wordpress.org/plugins/attachments/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jonathan Christopher

    (@jchristopher)

    Related to your other post, this issue will be looked into for the next release. You can manually process the occurrences of \n using str_replace for the time being until the next release comes out if you’d like.

    jbx

    (@jbx)

    Hi,

    How can I do that?
    The \n is appearing in the administrator not just the output text.
    How do I include this in the administrator side?

    Thanks.

    Plugin Author Jonathan Christopher

    (@jchristopher)

    Hi jbx so sorry for letting this thread fall by the wayside. I’ve got an update (3.5.2) coming out within an hour or two that will resolve this issue and a couple others that snuck in.

    Plugin Author Jonathan Christopher

    (@jchristopher)

    This issue has been resolved as of 3.5.2

    Thanks, issue seems fixed now.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem with new lines in caption textareas’ is closed to new replies.