Support » Plugin: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) » Problem with multiple markers on Layer map with wordpress on his own directory

  • Resolved jintos

    (@jintos)



    Hi,

    I have a problem to display marker on layer with my wordpress install.

    I have a custom folder directory for my project (https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory) :

    – cms <- wordpress folder
    – content <- wp-content folder
    — languages
    — plugins
    — themes
    — upgrade
    — uploads
    .htaccess
    index.php
    wp-config.php

    When I create a new Layer and add a new marker on this layer, the marker doesn’t display on layer map…

    I tried with a basic wordpress structure and it works perfectly but not with my custom folder structure.

    The plugin failed just for display Marker on Layer map, all others features work fine.

    Have any idea about my problem and how to solve it ?

    https://wordpress.org/plugins/leaflet-maps-marker/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author RobertHarm

    (@harmr)

    Hi,
    actually I am not sure why this break the maps on your site – can you also post a link to a map please?
    In general I would suggest to at least not change the wp-content folder, as this might lead to issues from other plugins/themes too
    best,
    Robert

    Hi Robert,

    Here is a live example of my current problem : http://dev.jintos.fr/labo/

    There is a problem when i try to call the leaflet-geojson.php file.

    Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/labo/content/plugins/leaflet-maps-marker-pro/leaflet-geojson.php on line 7

    http://dev.jintos.fr/labo/content/plugins/leaflet-maps-marker/leaflet-geojson.php?layer=all&full=no&full_icon_url=no

    I tried to increase the maximum execution time in my php.ini to 600 sec but it don’t resolve anything…

    Plugin Author RobertHarm

    (@harmr)

    Hi,
    as the fullscreen map at http://dev.jintos.fr/labo/content/plugins/leaflet-maps-marker/leaflet-fullscreen.php?layer=1 also does not seem to work, I rather guess that this is not directly related to the execution time set in php.ini. Please check if you are using any security plugins or security configurations (e.g. in .htaccess) which prevent the execution of php files in /wp-content/* – I assume that this could be the reason for the issue…
    best,
    Robert

    Hi Robert,

    Unfortunately I do not use any security plugin and I have not changed the .htaccess file for the demo site (The .htaccess file contains only the structure of wordpress permalinks). This is the problem I imagined at first because I already have with other plugins but the current problem does not seem to be related.

    By connecting to the admin i get an SQL Error:

    ALTER TABLE jndb_labo_web_leafletmapsmarker_layers CHANGE COLUMN clustering clustering tinyint(1) unsigned NOT NULL
    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘clustering clustering tinyint(1) unsigned NOT NULL’ at line 1

    This maybe the problem ?

    What can I do to help you solve this problem ?

    Plugin Author RobertHarm

    (@harmr)

    Hi,
    the SQL error is not related to your issue & nothing to worry about.
    Have you tried if the issue also occurs with Maps Marker Pro? Please start a free 30 days trial and let me know if it works for you, so that I can change if there are any related difference with the free version.
    best,
    Robert

    Hi Robert,

    The first time I encountered this problem was with the pro trial version , so I try with the free version but the problem exists on both version. The problem exists in Admin view and Front View…

    I’d really like to take a pro license of your plugin for one of my clients. I think it is the best plugin in its category.

    I added a card with the pro version on the demo site : http://dev.jintos.fr/labo/

    You’ll find that when you click on a marker JS error is obtained because the markers are not present on the map.

    Another thing that can possibly help you :
    Microformats for each markers are present on the page, I can see it with the extension “Microformats” in google Chrome

    Plugin Author RobertHarm

    (@harmr)

    if you send me a temporary admin access (info (a) mapsmarker.com), I can have a look if I find out more later this weekend

    Ok, can you gve your email adress, i will send you an admin acces.

    It’s Ok I find your email adress on your profil 😉

    Robert,

    You can check you mailbox, you have Login to connect to the admin of my demo site.

    Sorry I’m blind…, I had not seen the email address you put in the previous post 🙁 I send back the email to the right place …

    Plugin Author RobertHarm

    (@harmr)

    Hi,

    thanks for the access data – took a look. Can you please verify that the following plugin file (which is needed to load markers on layer maps) is available on your server:

    http://dev.jintos.fr/labo/content/plugins/leaflet-maps-marker-pro/leaflet-geojson.php?layer=1

    I tried to load this URL manually but didnt receive any result. As the readme is accessible via http://dev.jintos.fr/labo/content/plugins/leaflet-maps-marker-pro/readme.txt I assume that your server is not configured to display php files directly in the plugin directory. Either file permissions are not correct or – as stated before – executing of php files is somehow blocked on your server.

    I would suggest asking your hoster for assistance if there are any special configurations preventing the direct access of http://dev.jintos.fr/labo/content/plugins/leaflet-maps-marker-pro/leaflet-geojson.php?layer=1 for example (FYI: there are some other files in the plugin directly which need to be accessed directly)
    best,

    Robert

    Hi Robert,

    I checked all the settings on the servers I use in development and production. The folder “content” has the correct permissions to read and write … When I return to a classic wordpress folder structure, all perfectly works in combination …

    I did some research and try with the starter kit of Mark Jaquith -> Skeleton WordPress. https://github.com/markjaquith/WordPress-Skeleton
    The structure of wordpress files is the same as the one I use and am having the exact same problem with my folder structure …

    There are some issues that seem to present the problem that I encounter: https://github.com/markjaquith/WordPress-Skeleton/issues/38

    So I think the problem comes from the custom structure that I use. PHP files in the “plugins” folder can not seem to run if the wp-content folder is not located in the same folder as the WordPress files…

    The only solution I have found to operate the cards with several markers is to return to a classic wordpress folder structure …

    Could you (if you have time) test your plugin with using the WordPress Skeleton starter kit of Mark Jaquith and tell me if you encounter the problem too ?

    Thanks a lot for your help.

    Plugin Author RobertHarm

    (@harmr)

    Hi,
    the issues could be related, as e.g. the leaflet-fullscreen.php as well as all other plugin files which need direct access use the following code to initiate a WordPress instance:
    //info: construct path to wp-load.php and get $wp_path
    while(!is_file(‘wp-load.php’)) {
    if(is_dir(‘..’ . DIRECTORY_SEPARATOR)) chdir(‘..’ . DIRECTORY_SEPARATOR);
    else die(‘Error: Could not construct path to wp-load.php – please check https://www.mapsmarker.com/path-error for more details’);
    }
    include( ‘wp-load.php’ );
    Can you please check if there are any issues with your wp-load.php file? If I try to access that file directly on your server (http://dev.jintos.fr/wp-load.php) I get the error Service Unavailable, whereas actually I should get a blank page (checked with other WordPress instances I manage)
    best,
    Robert

    Hi Robert,

    If you check this adress you can access the wp-load.php :

    http://dev.jintos.fr/labo/cms/wp-load.php

    The Site url is http://dev.jintos.fr/labo
    The WordPress Url is http://dev.jintos.fr/labo/cms

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Problem with multiple markers on Layer map with wordpress on his own directory’ is closed to new replies.