WordPress.org

Forums

[resolved] Problem with moving site to a new host (6 posts)

  1. hfmason
    Member
    Posted 1 year ago #

    I've just moved two wordpress websites with individual databases from a 1&1 host to an iPage host.

    The first install was fine (www.hannahscottjoynt.com) but the second I keep getting 'Error establishing database' (www.studiomanifold.org).

    I've triple checked for any typos in the wp-config file and have tried adding a unique name for the table_prefix and keeping it as 'wp_' too.

    Has anyone got anything else I can try?

    Thanks

  2. Tara
    Volunteer Moderator
    Posted 1 year ago #

    Related:
    http://codex.wordpress.org/Moving_WordPress
    http://wordpress.org/plugins/wp-migrate-db/

    Error connecting to your database:
    Error connecting to your database is common, but it isn't necessarily a problem with wordpress itself.
    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur. - Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider. - Check you have actually created a database with the same database name as is in your wp-config.php file.
    - Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc.
    - There are also many threads on this topic on these forums: http://wordpress.org/search/Error+establishing+a+database+connection?forums=1

  3. hfmason
    Member
    Posted 1 year ago #

    Thanks Tara.

    I suppose I'm just confused that one database worked but another didn't. Wp-config has been checked a lot. I'll contact the host and see if there's a problem with that specific one.

  4. SKTThemes
    Member
    Posted 1 year ago #

    Yes also check if the host section has to be kept localhost or do you have to place host. In 1and1 you might have kept a hostname but in iPage you have to keep localhost.

    This might also be the problem.

    Also kindly check the password. If not kindly go to mysql databases in iPage host and reset the password of db and try the new password.

  5. hfmason
    Member
    Posted 1 year ago #

    Problem solved!

    Deleted the old database and created a new one.

    and

    Downloaded the latest wordpress (I forgot I had updated since I installed the first one) and used the current wp-config.php file.

    Thanks for your help.

  6. Tara
    Volunteer Moderator
    Posted 1 year ago #

    glad you got it sorted :)

Topic Closed

This topic has been closed to new replies.

About this Topic