Support » Plugin: Block Temporary Email » Problem with Mailpoet3

  • Resolved Debugger

    (@retrobeatcom)


    Just to let you know that there’s a problem when importing users to Mailpoet 3.
    I’ve tried to import a list with 9800 users and it times out after 5 minutes.

    You should add an option to the admin page where to validate emails only when a user is registering or changing his email address.

    I had to disable your plugin, so I can do the import.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author IsTempMail

    (@istempmail)

    Hi,

    Sorry for my late response.

    You can visit WordPress dashboard > Settings > IsTempMail, change the Hook behavior to “Check only emails submitted via browsers“.
    See screenshot:
    https://ps.w.org/block-temporary-email/assets/screenshot-3.png?rev=1757167

    I hope this helps.

    Thread Starter Debugger

    (@retrobeatcom)

    I had this option set.
    The problem is that the import of the emails in Mailpoet is through the web browser, so this does not solve the problem.
    Any other ideas?

    Plugin Author IsTempMail

    (@istempmail)

    Hi,

    Please update the plugin to version 1.4.2, then visit the settings page and enter
    /wp-admin/admin.php?page=mailpoet-
    into “No check on URIs”. It’ll stop checking emails on URI contains the string above, i.e. all MailPoet page under your WP dashboard.

    Let me know if it works for you.

    Thread Starter Debugger

    (@retrobeatcom)

    Sorry for the late reply.
    I am running Your latest version of the plugin and i am still unable to import emails without checking.

    Please advice.

    Plugin Author IsTempMail

    (@istempmail)

    Hi,

    Please deactivate, delete the plugin, then reinstall it. Make sure that the URI listed at “No check on URIs” is correct and matches your MailPoet import URL (see the import URL on your browser address).

    Let me know if it works for you.

    Thread Starter Debugger

    (@retrobeatcom)

    I can confirm that it still trying to verify each and every single email address when importing to Mailpoet.

    Bellow are my no check urls:

    /wp-admin/admin.php?page=mailpoet-
    /wp-admin/admin.php?page=mailpoet-import
    /wp-admin/admin.php?page=mailpoet-import#step2

    Any ideas? Are You sure that it is working on Your side?

    Plugin Author IsTempMail

    (@istempmail)

    Hi,

    I’ve checked and found that MailPoet sends the contents to /wp-admin/admin-ajax.php instead. So I updated our plugin to check the referer in case of AJAX requests.

    Please update the plugin to 1.4.4 and it should fix the problem.

    Let me know if it works for you.

    Thread Starter Debugger

    (@retrobeatcom)

    I confirm that the plugin now works correctly with Mailpoet.
    Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem with Mailpoet3’ is closed to new replies.