Support » Fixing WordPress » Problem with links formatting… Link Manager 2.0

  • I searched first and couldn’t find a solution. Here goes:

    I am using this:

    <?php get_links_list(); ?>

    to get the links on this page:

    http://www.jalopyjournal.com/wordpress/?page_id=9

    ———–

    Everything is working pretty well, so I go to the link manager to add a break between the link and the description. I do so, but it doesn’t take. In fact, I can put whatever jibberish I want in any of those fields (Before link, Before link and description, After link) and they have no effect at all on the page.

    What am I doing wrong??

    Thanks so much!

Viewing 8 replies - 1 through 8 (of 8 total)
  • I am about to give up on WORDPRESS. Everytime I try to link a website in a post Im creating..and the link is not live… the text for the site is there but you cant click on it … Im about to give up unless someone out there can help me.. Ive been told to just click LINK and enter in the website..but its not that easy ..please help!

    Link ryanc, I’ve noticed that despite the Before-Between-After setting of <li><br /></li>
    , the break doesn’t take. In fact, it does not appear in the resulting code at all. WP 2.0.3. I have Show-image set to false for the links categories. Any ideas?

    Yeah I’m having the same problem. There’s nothing rendered in between the links and their descriptions. Very annoying. It looks like this was a problem back in 1.5 also (on some builds). Can’t believe it hasn’t been fixed yet.

    I’m also having the same problem. Does anyone have any suggestions?

    if you guys are talking bout linking links in your blog you have to use the html on the toolbar of your blog and you have to type it there for it to work correctly.

    No, we’re talking about the Link Formatting problem; currently wp_get_links() completely ignores formatting let alone options that we set.

    I’m using 2.0.5 —

    It appears those attributes were overlooked when Dougal added the get_links_list() function, but the function comment specifies an unordered HTML list, which is correct.

    My solution:

    edit wp-includes/links.php

    Mod the function as follows:

    change the following lines (starting at 542-ish)

    foreach ($cats as $cat) {
    // Handle each category.
    // First, fix the sort_order info
    == trunc ===
    bool_from_yn($cat['show_updated']));
    // Close the last category
    echo "nt</ul>n</li>n";
    }

    to:

    foreach ($cats as $cat) {
    echo ' <li id="linkcat-' . $cat['link_category'] . '"><h2>' . $cat['cat_name'] . "</h2>nt<ul>n";
    wp_get_links($cat[link_category]);
    }

    I noticed that spaces between links won’t show up. So I added some spacer code to the style.css file and that seems to have solved the problem.

    I added:

    .spc {padding:0.5em;}

    to the style sheet, and then called it
    like this: (li class=”spc”).

    Now all of my links have a space between them.

    This problem does not seem to show up if you use the default theme.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem with links formatting… Link Manager 2.0’ is closed to new replies.