Support » Plugin: Yoast SEO » Problem with link rel=”canonical”

  • Resolved visitmontaione

    (@visitmontaione)


    I have a wordpress website, and I just realized that ALL pages of the website has parameter for canonical url that point to the home page like this.

    <link rel=”canonical” href=”/” />
    This causing me some problems seo side. I use Yoast Seo, and I have not made any other settings. how can I delete it?

    Thanks for help.

    Filippo

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi @visitmontaione!

    We would like some more information to help us troubleshoot.

    1. If you go to the Yoast SEO Metabox and find the Advanced section and click on it, is there anything in the canonical part? See image https://ibb.co/4mbb9RN.

    2. Are all your non-Yoast plugins and themes also updated?

    3. If it is blank and all are updated, if you use the Yoast Helper Tool does the issue resolve? Please try the steps below:
    – i. Install & activate the Yoast Test Helper plugin: https://wordpress.org/plugins/yoast-test-helper/
    – ii. Go to Tools -> Yoast Test
    – iii. Locate the Yoast SEO section and select the “Reset indexables tables & migrations” button
    – iv. Click the “SEO Data” button in the SEO->Tools section.

    Thread Starter visitmontaione

    (@visitmontaione)

    Hello pcosta88, Yes I saw the Advanced section, and I always leave empty. I don’t think this is the reason of this issue. I can’t write an url for each page. It take lot of time for a site with 1200 pages.

    Plugins and theme are all updated

    I will try the Yoast Test Helper, hope it will do the job.
    Thanks

    Thread Starter visitmontaione

    (@visitmontaione)

    Hello just tried to do your instructions.
    Performing the last step, after some minutes, I got this message:

    Oops, something has gone wrong and we couldn’t complete the optimization of your SEO data. Please click the button again to re-start the process.

    And all pages still have <link rel=”canonical” href=”/” />

    How can I proceed? Should I perform “Start SEO data optimization” again?

    Plugin Support devnihil

    (@devnihil)

    @visitmontaione Thanks for your reply and please let us know whether resetting the indexables resolves the issue for you.

    Thread Starter visitmontaione

    (@visitmontaione)

    Hello devnihil, it has not solved this issue…

    Should I do it for a second time?

    Thread Starter visitmontaione

    (@visitmontaione)

    This is the code: `

    
    <!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
    	<title>Vacanza in bicicletta a Montaione e ciclismo in Toscana. Noleggio mountain bike, percorsi e itinerari per scoprire il paesaggio della campagna del chianti.</title>
    	<meta name="description" content="Vacanza in Toscana con la mountain bike a noleggio nella campagna di Montaione, vacanze sportive e cicloturismo, percorsi per mountainbike e bici da corsa." />
    	<link rel="canonical" href="/" />
    	<meta property="og:locale" content="it_IT" />
    	<meta property="og:type" content="article" />
    	<meta property="og:title" content="Vacanza in bicicletta a Montaione e ciclismo in Toscana. Noleggio mountain bike, percorsi e itinerari per scoprire il paesaggio della campagna del chianti." />
    	<meta property="og:description" content="Vacanza in Toscana con la mountain bike a noleggio nella campagna di Montaione, vacanze sportive e cicloturismo, percorsi per mountainbike e bici da corsa." />
    	<meta property="og:url" content="https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/ciclismo/" />
    	<meta property="og:site_name" content="VisitMontaione.com" />
    	<meta property="article:modified_time" content="2020-12-06T14:06:59+00:00" />
    	<meta name="twitter:card" content="summary_large_image" />
    	<meta name="twitter:label1" content="Tempo di lettura stimato">
    	<meta name="twitter:data1" content="2 minuti">
    	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.visitmontaione.com/it/#website","url":"https://www.visitmontaione.com/it/","name":"VisitMontaione.com","description":"VisitMontaione.com - Portale turistico di Montaione","potentialAction":[{"@type":"SearchAction","target":"https://www.visitmontaione.com/it/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"it-IT"},{"@type":"WebPage","@id":"https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/ciclismo/#webpage","url":"https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/ciclismo/","name":"Vacanza in bicicletta a Montaione e ciclismo in Toscana. Noleggio mountain bike, percorsi e itinerari per scoprire il paesaggio della campagna del chianti.","isPartOf":{"@id":"https://www.visitmontaione.com/it/#website"},"datePublished":"2012-10-15T07:23:56+00:00","dateModified":"2020-12-06T14:06:59+00:00","description":"Vacanza in Toscana con la mountain bike a noleggio nella campagna di Montaione, vacanze sportive e cicloturismo, percorsi per mountainbike e bici da corsa.","breadcrumb":{"@id":"https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/ciclismo/#breadcrumb"},"inLanguage":"it-IT","potentialAction":[{"@type":"ReadAction","target":["https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/ciclismo/"]}]},{"@type":"BreadcrumbList","@id":"https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/ciclismo/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.visitmontaione.com/it/","url":"https://www.visitmontaione.com/it/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.visitmontaione.com/it/cosa-fare/","url":"https://www.visitmontaione.com/it/cosa-fare/","name":"Cosa fare"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/","url":"https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/","name":"Vacanze sportive"}},{"@type":"ListItem","position":4,"item":{"@type":"WebPage","@id":"https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/ciclismo/","url":"https://www.visitmontaione.com/it/cosa-fare/sport-e-tempo-libero/ciclismo/","name":"Ciclismo"}}]}]}</script>
    	<!-- / Yoast SEO plugin. -->
    
    • This reply was modified 1 year, 4 months ago by Yui.
    • This reply was modified 1 year, 4 months ago by Yui. Reason: please use CODE button for proper formatting
    Thread Starter visitmontaione

    (@visitmontaione)

    Hi, just done the second Start SEO data optimization with no errors but the <link rel=”canonical” href=”/” /> remain…
    If I deactivate yoast seo plugin, than all this script disappear an the <link rel=”canonical” href=”/” /> is correct.

    Plugin Support devnihil

    (@devnihil)

    @visitmontaione We’re sorry to hear that resetting the indexables didn’t correct the issue for you.

    We’d next recommend to try performing a conflict check to see whether another plugin or theme is interfering with the Yoast SEO plugin’s ability to output the canonical.

    The fastest way to do this is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Nineteen. Test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin allows you to run a conflict check without affecting normal visitors to your site.As we can imagine that you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts.

    Thread Starter visitmontaione

    (@visitmontaione)

    Hello devnihil, I’ve deactivated the other plugins but the issue remain. Only deactivating Yoast seo the issue is solved.

    I prefere not switching to another theme, because last time caused me some problems.

    I think reasonably that we can solve in another way. I give you another clue, instead of installing an umpteenth plugin.

    As I told you I run https://wordpress.org/plugins/yoast-test-helper/ without solving this issue…

    The code <link rel=”canonical” href=”/” /> is not present in the shop section of my website.

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @visitmontaione,

    The Health Check plugin doesn’t make any permanent or visible changes to your site if you switch themes, so it’s possible to use it on a live site without it affecting visitors to your site.

    We can imagine that deactivating your plugins or switching themes on a production site isn’t the best way to go. Have you ever considered setting up a staging environment for your tests? This means that you can do all the testing and only change the live site when all works like intended.

    Your host might be able to help
    Some popular web hosts offer quick setups for a staging site so please contact your web host for assistance. They will probably be able to help you out.

    Alternative options to set up a staging environment
    If your web host does not offer staging sites, the WordPress plugin repository offers staging plugins or you can create your own staging site.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Problem with link rel=”canonical”’ is closed to new replies.