WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Problem with line height

[Resolved] Problem with line height

  • Hello,

    I have “Magazine Basic” theme activated in my WP blog below:

    http://internetmarketing.club5152.com/

    I don’t know how to modify the line-height for the main part of my blog.
    I want modify POST and PAGES main content parts only, and keep the rest (sidebars, header ,..) unchanged.

    Any help please. Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • jasonpaulweber
    Member

    @jasonpaulweber

    In your magazine-basic theme’s style.css, change the line-height value in the body section, so you’ll see something like this:

    body {
    background: #FAFAFA;
    margin: 0 auto;
    color: #111111;
    font-size: 14px;
    font-family: Arial, Tahoma, Verdana;
    line-height: 23px;
    }

    Or something similar to whatever value you see fit. The more px or em of line-height you have, the greater the spacing between lines.

    Thanks Jasonpaulweber,

    But I am sorry, it did NOT work, it makes change nothing.
    I don’t know where can I fix this line-height problem.

    Any other advices please, I will be very thankful.

    jasonpaulweber
    Member

    @jasonpaulweber

    Well, I don’t know your theme, but it’s one of those line-height attributes in your style.css. Open up your style.css and click Control-F and search for line-height. Adjust one of them until you find the right one. It might be under mainwrapper or something, but I’d have to know your particular theme. For sure, though, it’s some line-height attribute in that file.

    For future reference, it’s even better if your theme has a custom CSS option. Then just paste the CSS in there, which will overwrite your style.css. This way, you’re not altering your theme’s core WordPress files, and so when the next upgrade comes out, you won’t lose all your changes.

    And don’t forget to clear your browser’s cache.

    Thanks again Mr Jasonpaulweber,

    My theme is “Magazine Basic” and YES it has a custom CSS option. I think I will try to use it.
    Just tell me please what do I have to add in the said custom CSS to change the line-height? Thanks in advance.

    jasonpaulweber
    Member

    @jasonpaulweber

    Add this in your Custom CSS:

    #leftcontent .entry p {
    margin: 0;
    padding: 0;
    line-height: 26px !important;
    }

    Refresh your browser, delete your site’s cache if you’re using a caching plugin. If that doesn’t work, just try a generic:

    p { line-height: 26px !important; }

    And adjust the values accordingly.

    Add this in your Custom CSS:

    #leftcontent .entry p {
    margin: 0;
    padding: 0;
    line-height: 26px !important;
    }

    It worked, thanks jasonpaulweber.

    jasonpaulweber
    Member

    @jasonpaulweber

    My pleasure … I didn’t know how your theme was set up, but that’s where Firebug comes in handy (if you’re using Firefox); you can see the classes and IDs your CSS uses. Good luck!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Problem with line height’ is closed to new replies.