Support » Plugin: Disable Gutenberg » Problem with latest update

  • Resolved webene2018

    (@webene2018)


    Hello,

    It appears that your latest update has an issue. After installing and activating the plugin, the “Block Editor” remains instead of the “Editor” link and it still opens Gutenberg. This is on the All Pages and All Posts views. The plugin this morning (v 1.4) worked fine. Please correct.

    Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • I am now having the same issue and can confirm that Version 1.5.1 is not working to disable Gutenberg or the Block editor, or whatever the heck they are calling this monstrosity now… (sigh)!

    I have this issue too across 10 sites, including 2 multisites.

    • This reply was modified 1 year, 10 months ago by kestrel2. Reason: incorrect information
    • This reply was modified 1 year, 10 months ago by kestrel2.

    Seeing the same thing here on several sites.

    Same here. Version 1.5.1 is not working to disable Gutenberg or the Block editor.

    Same here… 100+ sites. If you click the title it uses the classic editor but if you hover over it, the menu is Block Editor.

    If you install the Classic Editor (https://wordpress.org/plugins/classic-editor/) in conjunction with Disable Gutenberg, it at least gets rid of the Block Editor link.

    Plugin Author Jeff Starr

    (@specialk)

    Hello everyone, allow me to explain what I think is happening here.

    The new version (1.5) of Disable Gutenberg adds alternate links to the Block Editor on any post where Gutenberg is disabled. So when you hover over a post on the Posts screen, you will see the usual “Edit” link, and then a new link for “Block Editor”.

    If you click the Edit link, the post will open the post in Classic Editor. Or if you click the Block Editor link, the post will open in the Block Editor. It’s just there to make life easier, if you want it.

    If you do NOT want to display any links to the Block Editor, you can disable the feature in the plugin settings (under “More Tools”).

    I hope that helps, let me know if any other issues, glad to help!

    Why wouldn’t this be the default settings? Most of us are probably installing this plugin to Disable Gutenberg completely. Just my 2 cents.

    Plugin Author Jeff Starr

    (@specialk)

    Yes, I am updating the plugin again today to change the option’s default value to disabled (show the shortcut edit links will not be displayed). Should have been done in the first place, you are absolutely correct.

    • This reply was modified 1 year, 10 months ago by Jeff Starr.

    I have the issue with the EDIT link only showing; no Block edit – which takes me to Gutenberg. (Even after the latest update).

    Fix?

    PS Activated Classic Editor plugin and disabled this. Now it works.
    =========

    “The new version (1.5) of Disable Gutenberg adds alternate links to the Block Editor on any post where Gutenberg is disabled. So when you hover over a post on the Posts screen, you will see the usual “Edit” link, and then a new link for “Block Editor”.

    If you click the Edit link, the post will open the post in Classic Editor. Or if you click the Block Editor link, the post will open in the Block Editor. It’s just there to make life easier, if you want it.”

    Plugin Author Jeff Starr

    (@specialk)

    Where did you find that info — it needs to be updated.

    As of DG 1.5.2, the classic/block edit and menu shortcut links are disabled by default. But you can enable them in the plugin settings. Then once they are enabled, the feature description you cite is correct.

    • This reply was modified 1 year, 10 months ago by Jeff Starr. Reason: clarity
    Plugin Author Jeff Starr

    (@specialk)

    It’s just an option that you have to enable. It is located in the plugin settings under “More Tools”.

    Jeff, Though the explanation did not fit my scenario exactly, the update did resolve my issue. Thank you for all the work you do!

    Plugin Author Jeff Starr

    (@specialk)

    Awesome thank you Kerry! 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Problem with latest update’ is closed to new replies.