Support » Plugin: Specific Content for Mobile » Problem with last version

  • Resolved Gilou24

    (@gilou24)


    Hello,
    The latest update says “Changed: Mobile page versin not anymore private to avoid issues caused by some SEO plugins”.
    But, as you can see here (https://i.imgur.com/3KgiJ7q.jpeg), already created mobile page versions are still private.
    But above all, on the list of pages, there is no longer a link to create the mobile version (see here: https://un-jardin-bio.com/tmp/Sans%20titre.m4v) – There is a long time since I created pages for mobile, but it seems to me that there was previously a link “Create a mobile page” … no?
    I am using Lite Speed Cache plugin …
    Best regards,
    Gilles

    • This topic was modified 3 months, 3 weeks ago by Gilou24.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter Gilou24

    (@gilou24)

    Sorry, I use Rank Math SEO (pro) plugin…

    Plugin Author Jose

    (@giuse)

    Hi @gilou24

    About the private status.
    Please, change manually the status to the public to the mobile pages.

    About the missing link to creating the mobile version.
    The new version has nothing different that can be related to this last issue.
    Also, other users have reported this issue in the past on previous versions, but they had never given me the information I need to check it.
    Here you can see the thread: https://wordpress.org/support/topic/my-create-mobile-version-button-is-not-showing/
    I hope this is now a good time to get rid of it 🙂
    The page shown in the video is the blog page. This is extracted from the description of the plugin:
    “As a default, WordPress doesn’t output the blog page content before the posts loop.
    Some themes do it. In this case, the blog page content output before the loop is handled by the theme templates.
    The plugin will check if the theme declares support for the blog page mobile version, if not so the blog page mobile version may take the original desktop content.”

    If you need to have a different version of the content that is outputted before the loop of posts, you need a compatible theme.

    But you have also other problems as I see in the video. You also miss the column of Specific Content For Mobile.

    In the past Rank, Math PRO used to add some CSS that was hiding content added by Specific Content For Mobile. You can see the thread here: https://wordpress.org/support/topic/css-conflict-in-the-backend/
    I don’t exclude it’s a similar problem.
    I suggest you disable Rank Math PRO and check if you still miss the column of SCFM.

    If you still miss it, it may be another plugin or the theme. To check it, do the following:

    – Install Freesoul Deactivate Plugins
    – Go to Freesoul Deactivate Plugins — Backend
    – Go to the row “All Pages” and disable all the plugins and the theme, but Specific Content For Mobile
    – Check the preview
    – If it works, one of the plugins or the theme is having a conflict with SCFM. If so, activate the theme and then a plugin after the other until you don’t find which one is giving the conflict.

    Let me know if you need more clarification and help.

    • This reply was modified 3 months, 3 weeks ago by Jose.
    Thread Starter Gilou24

    (@gilou24)

    In fact, not having recently created a mobile page, the problem may be older …
    I just deactivated Rank Math SEO. It doesn’t change anything.
    Well, I can’t afford to deactivate all plugins …
    But I installed the Health Check & Troubleshooting plugin which allows testing without changing anything on the blog on the visitor side.
    As you can see in the video (https://un-jardin-bio.com/tmp/plugin-deactivated.m4v), even with the default theme and all plugins disabled, except “Specific Content for Mobile”, the add mobile version button does not appear …

    Plugin Author Jose

    (@giuse)

    Hi @gilou24

    thank you for doing the test and giving me the information.

    Can you please inspect elements on the list of pages and look for “eos_scfm_device”?
    (Right-click => Inspect => Search “eos_scfm_device”).

    This is to know if the column is missing or only hidden from some mysterious CSS.

    Plugin Author Jose

    (@giuse)

    @gilou24

    Please also check that you have no mu-plugin that is running when you use Health Check & Troubleshooting.

    Go to the page of plugins and click on Must-use. Let me know if you see some mu-plugins there. If you see something that code runs even if with Health Check & Troubleshooting you disable all plugins.

    Thread Starter Gilou24

    (@gilou24)

    I just sent you, via the contact form of your website, the copy of the environment information concerning my blog.
    Hope this can help you solve this problem.

    Thread Starter Gilou24

    (@gilou24)

    Ok, mu-plugins did indeed contain the following files:
    freesoul deactivate plugins [fdp]
    Health Check Troubleshooting Mode
    passwords-functions.php
    I temporarily deleted these files to verify, but that did not resolve the issue

    Thread Starter Gilou24

    (@gilou24)

    I have also just done the inspection test of the elements … which seem to be present (see here: https://i.imgur.com/tzaarwW.jpeg)

    Plugin Author Jose

    (@giuse)

    Thank you @gilou24

    In the screenshot you shared I see SCFM is loading its stylesheet. This means SCFM is loading, but I don’t see if the HTML added by SCFM is present.

    You should click on “Elements” and look for “eos_scfm_device”.

    You should find something like:

    <th scope=”col” id=”eos_scfm_device” class=”manage-column column-eos_scfm_device”><span class=”dashicons dashicons-desktop”></span>|<span class=”dashicons dashicons-smartphone”></span></th>

    Can you find it?

    Thread Starter Gilou24

    (@gilou24)

    I don’t see these elements …

    Plugin Author Jose

    (@giuse)

    Hi @gilou24

    as written in the email the problem is solved, so I will close this thread.

    For the readers of this thread: please, fix the missing “create mobile version” link and the missing column in the list of posts and pages, updating the plugin to version 0.1.8.1

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.