WordPress.org

Forums

Contact Form
[resolved] Problem with languages (5 posts)

  1. booking
    Member
    Posted 11 months ago #

    Good day,

    I want to use the code of translation with qtranslate, but when I use a shortcode as, for example, [bestwebsoft_contact_form lang=fr], it doesn't work. The plugin works only with [contact_form] and [bestwebsoft_contact_form lang=en], but It shows only the mothertoe language of my site.

    https://wordpress.org/plugins/contact-form-plugin/

  2. toshocorp
    Member
    Posted 11 months ago #

    Hey booking,

    How to add the contact form not in English?

    Add a language in the block "Language settings for the field names in the form" on the plugin settings page.

    Mark the check box (if it's not marked yet) in the block "Change the names of the contact form fields and error messages", choose the necessary tab and fill in the fields. Choose the necessary tab in the block "Action after email is sent" as well and fill in the field. Save the changes.

    You will see the shortcode under the tab with the necessary language. (really small font :)) Please paste that shortcode to the page or post.

    Good luck,

  3. bestwebsoft
    Member
    Plugin Author

    Posted 11 months ago #

    Hi,

    1. Please go to settings page 'wp-admin/admin.php?page=contact_form.php', open the block 'Additional options'. If necessary, add a language in the block "Language settings for the field names in the form" on the plugin settings page.
    2. Mark the check box (if it's not marked yet) in the block "Change the labels of the contact form fields and error messages", choose the necessary tab, click the twistie to expand the list of the fields and fill in the fields. Choose the necessary tab in the block "Action after email is sent" as well and fill in the field. Save the changes.
    3. You will see the shortcode under the tab with the necessary language. Please paste that shortcode to the page or post.

    Sincerely,
    BestWebSoft Support Team

  4. booking
    Member
    Posted 11 months ago #

    Solved

  5. Karmux
    Member
    Posted 6 months ago #

    If there is already complete translation in plugin's languages folder, why all the fields must be filled in manually? They should automatically loaded from translation file.

Reply

You must log in to post.

About this Plugin

About this Topic