Support » Plugin: A-Z Listing » Problem with jump anchors (links) in mobile

  • Resolved ogral

    (@ogral)


    Hi, the plugin is working well (I’m using shortcodes) in the desktop version. I even follow your steps for no columns (php) and the layout looks well on mobile and desktop.

    The problem is that the anchors/links don’t work on mobile (both android and iOS)… I included another index in the mobile version to compare and it works (so I “guess” the theme is ok), but I prefer your plugin layout and versatility with taxonomies.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Daniel Llewellyn

    (@diddledan)

    I have no idea what’s going wrong. The alternative plugin on your page that does work is using exactly the same pattern that I’m using in this plugin. So I don’t know why my plugin would behave any differently. The clicks are correctly recognised and the address gets updated with the #letter-D (example) suffix, which the other plugin does exactly the same. Once the suffix is on the address the browser should scroll the page appropriately unless prevented by javascript.

    I’ve tried debugging the javascript but can’t find anything that is preventing the scroll from occurring. The only insight I can provide is that it seems that 1000pixels is a magic number – if the window is wider then the page will correctly scroll, but the moment it falls below 1000px width the page stops responding appropriately. This seems telling considering that the magic number appears to be the breakpoint your theme is using to switch between layouts.

    Sorry I can’t help much beyond this 🙁

    Thanks for your fast response… I “solved it”… The problem (on my end) was using 2 instances in VC (in two rows, 1 for desktop and 1 for mobile)… which created the conflict in mobile but not on “desktop”.

    • This reply was modified 5 months, 1 week ago by  ogral. Reason: resolved
    Plugin Author Daniel Llewellyn

    (@diddledan)

    I’m really glad you figured it out. I was completely lost 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.