Support » Installing WordPress » Problem With Innstall

  • The Massage say:
    Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the DB_NAME database.

    * Are you sure it exists?
    * Does the user b17_5310360 have permission to use the DB_NAME database?
    * On some systems the name of your database is prefixed with your username, so it would be like username_DB_NAME. Could that be the problem?

    If you don’t know how to setup a database you should contact your host. If all else fails you may find help at the WordPress Support Forums.

    I think this is a big problem. Yes today I install for the first time and it work but i was uploading a new theme and everything was gone. so i setup a new database and a new server and this is coming up. i don’t know whats wrong because everything is Right in the “wp-config.php” file. Please help me.

    Web side =

Viewing 6 replies - 1 through 6 (of 6 total)
  • You have to provide a name for your database, when you created it you should have a name.

    yeh. but is free. I have never don this before.

    [mod note: Please keep the language civil]

    Moderator Ipstenu (Mika Epstein)


    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    You’d have to ask your host how to sort out what your DB name is.

    Go here:

    Scroll to the bottom.

    Watch their directions on how to make a database.

    I have a database Name and everything is ok… I also use FileZilla.
    My Wp-Config.php

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘’);

    /** MySQL database username */
    define(‘DB_USER’, ‘b32_5306765’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘My secret’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    – can u see somthing wrong in this? πŸ™‚

    I follow this video

    Moderator Ipstenu (Mika Epstein)


    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    The DB name is not

    The DB name is something like wordpress or … well in the video at the 2:06 mark, there’s mention of creating a database and they highlight the name. THAT’s what you want, not http:// whatever.

    Ohh.. I can’t get it to work…. can someone heap me?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Problem With Innstall’ is closed to new replies.