WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Problem With Images Showing

[Resolved] Problem With Images Showing

  • Hello,

    I have just installed my second version of wordpress on my host, the first is under public_html and the second fmdatabase.net. I am using the exact same theme, just edited colours and some of the images arent showing on the second install, images are also missing from admin area. Anyone know whats wrong?

    http://www.fmgames.nethttp://www.fmdatabase.net

    Thanks

Viewing 15 replies - 1 through 15 (of 17 total)
  • FTP re-upload image folder of theme because images are missing from server.

    Is it nothing to do with having two installs on one server? Ive just checked and the images have been uploaded

    It looks like you have something wrong with your rewrites:

    http://www.fmdatabase.net/wp-content/themes/flexi-blue/img/find.gif

    Becomes in the browser (note the incorrect trailing slash):

    http://www.fmdatabase.net/wp-content/themes/flexi-blue/img/find.gif/

    BTW, you need to have at least one post in http://www.fmdatabase.net/ even though you are still setting up your site. Also, your site needs a 404.php so that 404’s, like that for the image are shown instead of the index page.

    Any ideas on how to correct this then? What folders/files need to rewrites changed?

    Anyone? 🙂

    Well, i have tried everything, changed the urls so they are direct and changed file attributes and still no change, anybody any clue whats going on?

    http://www.fmdatabase.net

    Thank you!

    dude your pointing to the wrong URL somewhere..

    where is your additional theme located? where is it in relation to the other theme that you mentioned? (and assuming the other theme displays the img’s correctly)…

    Are the themes peers as far as directory structure in concerned? or are they in different directories?

    here is a really easy way to play… copy the directory which has the functioning img files in it so it’s on your clipboard..

    go the the exact place your residual HTML (your page as seen in a browser) points to when looking for image files.. note it..

    find in your web structure that exact place.. paste your directory with the img files there.. if it works, your theme is simply referencing the wrong place while calling img’s.. which is what it looks to me is happening.

    Well i have two installs of wordpress, both under public_html however, fmdatabase is under a domain fmdatabase.net. I am using both the same themes, and it works with one and not the other (Fmgames – Fmdatabase). Theme is located under wp-content/themes/… its where the default theme is located

    I cant locate the problem, and i dont think its a problem with the theme because the images are missing from the admin area too, theres no images showing for the site at all.

    http://www.fmgdatabase.net

    No problems with using the same theme on the same host at http://www.fmgames.net

    Strange, anymore ideas guys? Thanks for your help so far

    Look in your .htaccess file for any rewrites and try disabling all plugins (especially any rewrite ones) to see if the problem goes away.

    change themes on that install and see if a embedded theme does the same thing.

    go to a browser and type in a URL to one of the missing image files.. you’ll see a failed php load.. my contention something is wrong with that copy of the theme.. copy the same theme from the other install and load it on the faulty one- over write it.. or delete it and fresh install it.. may be easier than trying to chase down this issue any further

    Not sure how to do the rewrites thing in htacess.

    Tried a different theme and it didnt work. The thing is, no images show for this site at all, even in the admin. Look below, no images are appearing 🙁

    http://img116.imageshack.us/my.php?image=noimagesl1.jpg

    Maybe something is weird in your add-on domain setup. Contact your web host.

    i simply don’t have a current copy to pilfer right now, but try this..

    erase/uninstall that WP completely.. install a fresh copy.. copy your theme to the fresh copy.. if your feeling all detectivly you can scour for the issue.. or you can just install fresh and be done with it..

    just my .20 (inflation)

    Hey guys.

    Fixed the problem with images showing in the admin area, it was due to hotlink protection, however images still arent showing for the theme :S

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Problem With Images Showing’ is closed to new replies.
Skip to toolbar